Package Details: ssvnc 1.0.29-10

Git Clone URL: https://aur.archlinux.org/ssvnc.git (read-only)
Package Base: ssvnc
Description: SSL/SSH VNC viewer
Upstream URL: http://www.karlrunge.com/x11vnc/ssvnc.html
Licenses: GPL
Groups: network
Submitter: adlerweb
Maintainer: jose1711
Last Packager: jose1711
Votes: 33
Popularity: 0.013416
First Submitted: 2010-01-17 00:46
Last Updated: 2019-07-26 19:47

Dependencies (13)

Sources (3)

Latest Comments

1 2 3 Next › Last »

thithib commented on 2019-07-26 19:07

Thanks @jose1711! Also, I just noticed that stunnel was listed in both depends and optdepends.

jose1711 commented on 2019-07-26 16:51

@thithib thank you for the additional info - i've updated the PKGBUILD

thithib commented on 2019-07-26 14:12

@jose1711

Yes actually the problem seems to only occur when building with makechrootpkg (the build works fine with makepkg). Using patch -p0 < "$srcdir/Makefile.patch" instead of patch -p0 < "../../Makefile.patch" fixes the build for me. I'm not sure why you're not using $srcdir here - especially since you do so on the preceding line - but from my understanding of the Arch Linux build system it would be better.

jose1711 commented on 2019-07-26 10:18

@thithib

i cannot reproduce the issue. archlinux java is set to java-12-openjdk.

thithib commented on 2019-07-21 00:00

Got the following error when building:

==> Starting prepare()... patching file vncstorepw/ultravnc_dsm_helper.c /startdir/PKGBUILD: line 25: ../../Makefile.patch: No such file or directory ==> ERROR: A failure occurred in prepare(). Aborting...

jose1711 commented on 2019-06-19 16:41

@maxdevaine fixed, thanks max

maxdevaine commented on 2019-06-18 08:07

Hello,

compilation give this error :
error: Source option 1.4 is no longer supported. Use 7 or later.

So, is neccessary to patch "ultraftp/Makefile" file. Like this "Makefile.patch" (just remove line "JC_ARGS = -target 1.4 -source 1.4") :

--- ultraftp/Makefile 2019-06-18 10:04:13.000000000 +0200
+++ ../../Makefile 2019-06-18 10:03:52.000000000 +0200
@@ -3,7 +3,6 @@
SOURCES = $(shell echo *.java)
CLASSES = $(SOURCES:%.java=%.class)
ARCHIVE = ultraftp.jar
-JC_ARGS = -target 1.4 -source 1.4

all: $(CLASSES) $(ARCHIVE)

and PKGBUILD should look like this :

...
source= (http://downloads.sf.net/sourceforge/$pkgname/$pkgname-$pkgver.src.tar.gz
openssl1.1.patch
Makefile.patch)

md5sums=('52201aeb0417c2a0fe83639e52da6ae5'
'6a119a5748a231f63c96044a2761845f'
'dd77c1dd3c3945a24be0046f4e7c7c7c')

prepare() {
cd "$srcdir/$pkgname-$pkgver"
patch -p1 < "$srcdir/openssl1.1.patch"
patch -p0 < "../../Makefile.patch"
}
...

Now all works fine.
Can you update your PKGBUILD?

Thanks
Max

mhertz commented on 2018-04-16 10:53

For file-transfer to work on non-reparenting WM's like ratpoison and dwm, I had to first run: "export _JAVA_AWT_WM_NONREPARENTING=1". I used JRE7-openjdk to test with, as lightest JRE. Either use it direct from ssvnc(the GUI frontend), or do like me and use just the ssvncviewer, and run with: "ssvncviewer host:port -env SSVNC_ULTRA_FTP_JAR=/usr/lib/ssvnc/util/ultraftp.jar". Btw, if wanting to have turbovnc's accelerated tight-encoding patch enabled for faster speed on LAN/fast-broadband, then i've posted a PKGBUILD link in my comment in the ssvnc-nojava aur package(top comment).

jose1711 commented on 2017-06-11 06:53

@accensi debian patch for openssl 1.1.0 has been adopted, should now work

accensi commented on 2017-06-10 12:35

Package is broken.

Several compilation errors in ultravnc.