Package Details: ssvnc-nojava 1.0.29-8

Git Clone URL: https://aur.archlinux.org/ssvnc-nojava.git (read-only)
Package Base: ssvnc-nojava
Description: SSL/SSH VNC viewer no java
Upstream URL: http://www.karlrunge.com/x11vnc/ssvnc.html
Licenses: GPL
Groups: network
Conflicts: ssvnc
Provides: ssvnc
Submitter: bidulock
Maintainer: bidulock
Last Packager: bidulock
Votes: 4
Popularity: 0.484203
First Submitted: 2014-07-25 13:11
Last Updated: 2019-07-26 19:45

Latest Comments

mhertz commented on 2019-05-13 23:24

Humble bump to add the debian openssl-1.1 patch also used by the full ssvnc package here, as currently the building fails.

mhertz commented on 2018-04-06 13:37

As already mentioned, this package cannot be built because it's missing the debian patch for openssl 1.1.0 included in the full ssvnc package, so here's an updated PKGBUILD which fixes this, plus some additional changes:

  1. As stated above, applies the openssl1.1 patch downloaded from debian's ssvnc package repo.

  2. Another useful debian patch is added which fixes some issues with the 'auto' scaling command/option.

  3. Upped version to last released one; development version v1.0.30, which fixes an openssl 1.x certificate fetching issue, possibly more.

  4. Enabled turbovnc's accelerated tight-encoding patch, which was evaluated for becoming default in ssvnc just before development stalled - Gives faster speed than regular tight encoding on LAN/fast-broadband.

https://pastebin.com/r4p7p51B

uffe commented on 2018-01-19 11:15

Please import the openssl patch from the full ssvnc aur package

uffe commented on 2018-01-19 11:14

Cannot build/compile:

ultravnc_dsm_helper.c:1410:14: error: storage size of ‘dctx’ isn’t known EVP_MD_CTX dctx; ^~~~

jose1711 commented on 2017-06-11 06:54

please note that a patch is needed to compile against openssl 1.1.0