Package Details: ssb-patchwork-git 3.10.1.r301.g9750bc4d-1

Git Clone URL: https://aur.archlinux.org/ssb-patchwork-git.git (read-only)
Package Base: ssb-patchwork-git
Description: A decentralized messaging and sharing app built on top of Secure Scuttlebutt (SSB)
Upstream URL: https://github.com/ssbc/patchwork
Licenses: AGPL3
Conflicts: ssb-patchwork
Provides: ssb-patchwork=3.10.1.r301.g9750bc4d
Submitter: christianbundy
Maintainer: christianbundy
Last Packager: christianbundy
Votes: 2
Popularity: 0.002699
First Submitted: 2018-07-25 02:13
Last Updated: 2019-02-13 17:20

Latest Comments

beroal commented on 2019-06-04 17:36

I cannot compile this.

==> Making package: ssb-patchwork-git 3.10.1.r301.g9750bc4d-1 (Tue 04 Jun 2019 08:34:47 PM EEST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Updating patchwork git repo...
Fetching origin
  -> Found run.sh
  -> Found ssb-patchwork.desktop
==> Validating source files with sha512sums...
    patchwork ... Skipped
    run.sh ... Passed
    ssb-patchwork.desktop ... Passed
==> Extracting sources...
  -> Creating working copy of patchwork git repo...
Reset branch 'makepkg'
==> Starting pkgver()...
==> Updated version: ssb-patchwork-git 3.12.0.r3.g88893c97-1
==> Removing existing $pkgdir/ directory...
==> Starting build()...

(electron2:1344): Gtk-WARNING **: 20:34:48.765: cannot open display:

> @felixrieseberg/spellchecker@4.0.8 install /var/abs/local/ssb-patchwork-git/src/patchwork/node_modules/@felixrieseberg/spellchecker > node-gyp rebuild

gyp WARN install got an error, rolling back install gyp ERR! configure error gyp ERR! stack Error: 404 response downloading https://atom.io/download/electron/v11.15.0/node-v11.15.0-headers.tar.gz gyp ERR! stack at Request.<anonymous> (/usr/lib/node_modules/node-gyp/lib/install.js:204:14) gyp ERR! stack at Request.emit (events.js:198:15) gyp ERR! stack at Request.onRequestResponse (/usr/lib/node_modules/node-gyp/node_modules/request/request.js:1066:10) gyp ERR! stack at ClientRequest.emit (events.js:193:13) gyp ERR! stack at HTTPParser.parserOnIncomingClient [as onIncoming] (_http_client.js:560:23) gyp ERR! stack at HTTPParser.parserOnHeadersComplete (_http_common.js:113:17) gyp ERR! stack at TLSSocket.socketOnData (_http_client.js:447:22) gyp ERR! stack at TLSSocket.emit (events.js:193:13) gyp ERR! stack at addChunk (_stream_readable.js:295:12) gyp ERR! stack at readableAddChunk (_stream_readable.js:276:11) gyp ERR! System Linux 5.1.6-arch1-1-ARCH gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/node-gyp/bin/node-gyp.js" "rebuild" gyp ERR! cwd /var/abs/local/ssb-patchwork-git/src/patchwork/node_modules/@felixrieseberg/spellchecker gyp ERR! node -v v11.15.0 gyp ERR! node-gyp -v v4.0.0 gyp ERR! not ok npm WARN acorn-dynamic-import@4.0.0 requires a peer of acorn@^6.0.0 but none is installed. You must install peer dependencies yourself. npm WARN acorn-jsx@5.0.1 requires a peer of acorn@^6.0.0 but none is installed. You must install peer dependencies yourself. npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules/fsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

npm ERR! code ELIFECYCLE npm ERR! errno 1 npm ERR! @felixrieseberg/spellchecker@4.0.8 install: node-gyp rebuild npm ERR! Exit status 1 npm ERR! npm ERR! Failed at the @felixrieseberg/spellchecker@4.0.8 install script. npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in: npm ERR! /home/compile/.npm/_logs/2019-06-04T17_34_55_801Z-debug.log ==> ERROR: A failure occurred in build(). Aborting...

Tav commented on 2019-04-12 16:30

Probably something simple. What executes the package once it is installed? I've tried several variations on the package name, but so far, no dice.

edit. Nevermind. I found it. Apparently electron wasn't installed which I suppose should be added as a required package to this build?

christianbundy commented on 2019-02-13 15:49

Please don't flag this package as out-of-date. It's a VCS package0 and the AUR only shows the last time that it was manually updated. When you download the package it will always install the latest version. If you're having trouble with the package, please leave a comment! I'm happy to help. :)