Package Details: srb2kart 1.1-2

Git Clone URL: https://aur.archlinux.org/srb2kart.git (read-only)
Package Base: srb2kart
Description: A kart racing mod based on the 3D Sonic the Hedgehog fangame Sonic Robo Blast 2, based on a modified version of Doom Legacy.
Upstream URL: https://mb.srb2.org/showthread.php?t=43708
Keywords: sonic_robo_blast_2 sonic_robo_blast_2_kart srb2 srb2kart
Licenses: GPL2
Submitter: SteelTitanium
Maintainer: SteelTitanium
Last Packager: SteelTitanium
Votes: 2
Popularity: 0.752460
First Submitted: 2019-01-21 04:28
Last Updated: 2019-06-28 04:50

Latest Comments

SteelTitanium commented on 2019-01-31 06:18

@birbhorse Random thought. But have you tried launching the game with -nomusic or -win? I wonder if this is an bugs that needs to be fixed upstream or not.

birbhorse commented on 2019-01-30 23:39

Hey there! After building this, I'm getting a bizzare error where after the game launches, the window refuses to actually render and instead opens and closes rapidly and repeatedly.

I'm using Antergos 64-bit, installed on 19.1. This installation is basically fresh since 2 days ago, with the only programs installed being Discord, Vivaldi, Inkscape, and some gnome themes (though I'm running on Budgie if that's of any help).

Here's a log: https://pastebin.com/neVze9Ab

Interestingly, SRB2, which is also on the AUR, has no issues running. Here's a log of regular SRB2 running: https://pastebin.com/AJa6ZeDp

EDIT: Just to clarify, I ran both without entering any prompt, e.g. "srb2kart" and "srb2". If I launch both using OpenGL, SRB2kart still has the same issue, and SRB2 still works fine.

I also tried running SRB2kart without sound using "srb2kart -nosound", since the logs indicated some issue with sound, but no difference occurred, it still crashed.

EDIT 2 (final one I swear): I also tried installing "lib32-alsa-plugins" per suggestion of a google search, still didn't fix the issue at hand.