Package Details: srb2 2.1.25-1

Git Clone URL: https://aur.archlinux.org/srb2.git (read-only)
Package Base: srb2
Description: A 3D Sonic fan game based off of Doom Legacy (aka "Sonic Robo Blast 2")
Upstream URL: http://www.srb2.org
Licenses: GPL
Submitter: None
Maintainer: carstene1ns
Last Packager: carstene1ns
Votes: 21
Popularity: 0.799515
First Submitted: 2010-11-22 00:26
Last Updated: 2019-08-28 20:20

Latest Comments

1 2 3 Next › Last »

SteelTitanium commented on 2019-06-12 02:48

Letting you know, as of 2.1.24 support for APNG got better, but it still requires a patched version of libpng.

xXShadicXx11 commented on 2019-02-20 23:46

Thank you very much for updating the package

SteelTitanium commented on 2019-01-20 19:26

Are you going to update this to 2.1.23 anytime soon?

SteelTitanium commented on 2018-01-15 03:20

Just letting you know, this is outdated as 2.1.20 was released two weeks ago, no need to update the data package, as no changes have been made to those. All of the fixes were code changes.

ArchLinuxGeek commented on 2016-11-19 16:43

carstene1ns, It is ok. I had a good learning experience trying to build the game from source. I was able to build the 64-bit and 32-bit versions after some experimentation and reading the build from source wiki of the game. I had to include NOPNG=1 in the build line to make the package build before the package was updated

carstene1ns commented on 2016-11-19 12:07

Thanks, JJK. Seems they forgot to include the `patch.dta` file in their 2.1.16 patch package, but moved it to the data archive... To avoid having a chicken-egg problem when updating to the next version, the patch data stays at 2.1.15 for this release, I have verified it is the same.

ArchLinuxGeek, sorry I missed your message, was only notified this week, when the package was flagged out-of-date. :/

ArchLinuxGeek commented on 2016-11-17 21:52

Thank you for the updated pkgbuild the package now works as version 2.1.16

JJK commented on 2016-11-17 13:26

I made an updated pkgbuild, you can just test it and replace
You can find it here
https://drive.google.com/open?id=0B9Ru5inoSs_6dVB0a093SkVoQzg

ArchLinuxGeek commented on 2016-10-10 01:06

Hi, While playing the game, in order to use the master server for the multiplayer I have run into the issue of needing version 2.1.16 however that version is not avaialbe on the AUR and when I have tried to compile it from the GitHub repository i run into the cmake error

"CMake Error at CMakeLists.txt:176 (prepend_sources):
Unknown CMake command "prepend_sources".


CMake Warning (dev) in CMakeLists.txt:
No cmake_minimum_required command is present. A line of code such as

cmake_minimum_required(VERSION 3.6)

should be added at the top of the file. The version specified may be lower
if you wish to support older CMake versions for this project. For more
information run "cmake --help-policy CMP0000".
This warning is for project developers. Use -Wno-dev to suppress it."

How can I fix this issue?

carstene1ns commented on 2014-08-17 05:10

@Furyhunter:
About libpng: I am not compiling without png support, if you read my comment and the PKGBUILD (again), you will find out I only disable _animated_ png support. This package built before with the old 1.2 branch version of libpng. Also, src/m_misc.c is a mess that sets many things about png and zlib to incompatible values.

About the patch data: Yeah, I already thought about something like this, as re-downloading the whole data package seems bad. The problem was the 'srb2-bin' package, that provided the executable as well and all 3 packages had to be kept in sync. I now filed a deletion request for that package, so this is no problem anymore and the patch data can be included here.