Package Details: spyder3-git 4.0.1.r51.gf818d7921-1

Git Clone URL: https://aur.archlinux.org/spyder-git.git (read-only, click to copy)
Package Base: spyder-git
Description: The Scientific Python Development Environment (Python 3 version)
Upstream URL: https://www.spyder-ide.org/
Licenses: MIT
Conflicts: spyder3
Provides: spyder3
Submitter: willemw
Maintainer: willemw
Last Packager: willemw
Votes: 22
Popularity: 0.034659
First Submitted: 2015-02-24 08:52
Last Updated: 2020-03-27 12:42

Latest Comments

1 2 3 4 5 6 ... Next › Last »

willemw commented on 2020-04-25 17:16

@fisherjf: I don't think this is a Spyder package issue. Spyder does not install /usr/bin/keyring.

Which package owns it now (pacman -Qo /usr/bin/keyring)? Maybe you need to do a system upgrade.

fisherjf commented on 2020-04-25 17:08

unable to install.

conflicting files: python-keyring: /usr/bin/keyring already exists in filesystem

willemw commented on 2020-03-14 09:14

depends=python-spyder-kernels is correct and you should select python-spyder-kernels-git yourself.

But for (temporary) convenience it can be set to depend=python-spyder-kernels-git. That is what I do for several other packages I maintain. For this package (spyder3-git), however, I did not think it was necessary.

trougnouf commented on 2020-03-14 09:01

spyder-kernels >= 1.0 is required (found 0.5.2).

The dependency should be python-spyder-kernels-git instead of python-spyder-kernels

j_4321 commented on 2019-11-26 15:55

spyder now requires python-intervaltree

willemw commented on 2019-11-13 08:57

Removed spyder (python 2 version). Added cloudpickle and numpydoc dependencies.

willemw commented on 2019-11-13 07:38

@daviding: the Arch Linux package name for pyls is python-language-server (0.29.1), which is already a dependency. The issue is that Spyder checks for a newer version (>=0.29.3;<0.30.0).

daviding commented on 2019-11-12 17:04

I also got the error ...

--begin paste --

RuntimeError: Please check Spyder installation requirements: spyder-kernels >= 1.0 is required (found 0.5.2).

-- end paste --

... and found python-spyder-kernels-git 1.7.0.r12.g2bcda3b-1 in AUR. I installed that.

Starting Spyder, there's a warning message:

-- begin paste --

You have missing dependencies!

numpydoc >=0.6.0 : None (NOK)
pyls >=0.29.3;<0.30.0: 0.29.1 (NOK)

Please install them to avoid this message.

-- end paste --

... and found python-numpydoc 0.9.1-1 in AUR. Installed that.

Another message ...

-- begin paste --

pyls >=0.29.3;<0.30.0: 0.29.1 (NOK)

-- end paste --

... and found python-pylsl 1.13.1-1 in AUR. Tried installing that unsuccessfully.

-- begin paste --

Cloning python-pylsl build files... Checking python-pylsl dependencies... Preparing... Warning: cannot resolve "liblsl", a dependency of "python-pylsl" Failed to prepare transaction: could not satisfy dependencies: unable to satisfy dependency 'liblsl' required by python-pylsl Failed to prepare transaction.

-- end paste --

willemw commented on 2019-10-05 06:52

@JohnRobson: Thanks. Added pympler dependency. Your spyder-kernels version is very old. Current version is 1.5.0.r2.gc303669-1.

JohnRobson commented on 2019-10-05 01:33

RuntimeError: Please check Spyder installation requirements: spyder-kernels >= 1.0 is required (found 0.4.4).

ModuleNotFoundError: No module named 'pympler'

dependencies: python-spyder-kernels-git python-pympler