Package Details: spyder3-git 4.0.0rc3.r1.g2d607299c-1

Git Clone URL: (read-only, click to copy)
Package Base: spyder-git
Description: The Scientific Python Development Environment (Python 3 version)
Upstream URL:
Licenses: MIT
Conflicts: spyder3
Provides: spyder3
Submitter: willemw
Maintainer: willemw
Last Packager: willemw
Votes: 23
Popularity: 0.47
First Submitted: 2015-02-24 08:52
Last Updated: 2019-11-27 14:10

Latest Comments

1 2 3 4 5 6 ... Next › Last »

j_4321 commented on 2019-11-26 15:55

spyder now requires python-intervaltree

willemw commented on 2019-11-13 08:57

Removed spyder (python 2 version). Added cloudpickle and numpydoc dependencies.

willemw commented on 2019-11-13 07:38

@daviding: the Arch Linux package name for pyls is python-language-server (0.29.1), which is already a dependency. The issue is that Spyder checks for a newer version (>=0.29.3;<0.30.0).

daviding commented on 2019-11-12 17:04

I also got the error ...

--begin paste --

RuntimeError: Please check Spyder installation requirements: spyder-kernels >= 1.0 is required (found 0.5.2).

-- end paste --

... and found python-spyder-kernels-git 1.7.0.r12.g2bcda3b-1 in AUR. I installed that.

Starting Spyder, there's a warning message:

-- begin paste --

You have missing dependencies!

numpydoc >=0.6.0 : None (NOK)
pyls >=0.29.3;<0.30.0: 0.29.1 (NOK)

Please install them to avoid this message.

-- end paste --

... and found python-numpydoc 0.9.1-1 in AUR. Installed that.

Another message ...

-- begin paste --

pyls >=0.29.3;<0.30.0: 0.29.1 (NOK)

-- end paste --

... and found python-pylsl 1.13.1-1 in AUR. Tried installing that unsuccessfully.

-- begin paste --

Cloning python-pylsl build files... Checking python-pylsl dependencies... Preparing... Warning: cannot resolve "liblsl", a dependency of "python-pylsl" Failed to prepare transaction: could not satisfy dependencies: unable to satisfy dependency 'liblsl' required by python-pylsl Failed to prepare transaction.

-- end paste --

willemw commented on 2019-10-05 06:52

@JohnRobson: Thanks. Added pympler dependency. Your spyder-kernels version is very old. Current version is 1.5.0.r2.gc303669-1.

JohnRobson commented on 2019-10-05 01:33

RuntimeError: Please check Spyder installation requirements: spyder-kernels >= 1.0 is required (found 0.4.4).

ModuleNotFoundError: No module named 'pympler'

dependencies: python-spyder-kernels-git python-pympler

willemw commented on 2019-09-26 19:17

@maciex: these dependencies are already defined.

maciex commented on 2019-09-26 19:09

missing dependencies: python2-keyring, python2-language-server, python-qdarkstyle

willemw commented on 2019-07-22 06:50


Added two dependencies.

The 'community/spyder' base package is also a split package (for now). You could also build the package in a clean chroot environment, if you don't want to install Python 2 on your system.

fabmazz commented on 2019-07-19 22:22

Now spyder 4 requires python-watchdog as a depedency. They just keep adding new ones....

Also, I think that building spyder for both python 2 and python 3 at the same time is confusing and not useful at all. I think it goes against the minimalist principle of Arch, and, given that Python 2 will soon reach EOL, is not useful at all.

If the packages could be split for different Python versions it would be great... otherwise I will continue to remove parts of the PKGBUILD each time xD