Package Details: spyder-git 5.0.5.r360.gd829e6db6-1

Git Clone URL: (read-only, click to copy)
Package Base: spyder-git
Description: The Scientific Python Development Environment
Upstream URL:
Licenses: MIT
Conflicts: spyder, spyder3-git
Provides: spyder
Replaces: spyder3-git
Submitter: willemw
Maintainer: willemw
Last Packager: willemw
Votes: 24
Popularity: 0.018280
First Submitted: 2015-02-24 08:52
Last Updated: 2021-07-10 14:42

Dependencies (47)

Required by (5)

Sources (1)

Pinned Comments

willemw commented on 2020-08-05 07:20


Some dependencies may need to be downgraded.

Alternatively, try to edit the requirements file ("requirements/conda.txt" in the source files or "requires.txt" in the installed files).

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 ... Next › Last »

contrebasse commented on 2016-06-17 23:01

@JohnRobson Downgrade qtpy, spyder is not yet compatible with qtpy master.

JohnRobson commented on 2016-06-17 18:40

check_qt() function in /usr/lib/python3.5/site-packages/spyderlib/

This function has this problem:

$ /usr/bin/python3.5 /usr/bin/spyder3
Traceback (most recent call last):
File "/usr/bin/spyder3", line 3, in <module>
File "/usr/lib/python3.5/site-packages/spyderlib/app/", line 118, in main
from import spyder
File "/usr/lib/python3.5/site-packages/spyderlib/app/", line 48, in <module>
File "/usr/lib/python3.5/site-packages/spyderlib/", line 46, in check_qt
% (package_name, required_ver, actual_ver))
File "/usr/lib/python3.5/site-packages/spyderlib/", line 25, in show_warning
raise RuntimeError(message)
RuntimeError: Please check Spyder installation requirements:
PyQt5 5.2+ is required (found v1.1.0.dev0).

Even after update: python-qtpy-git python2-qtpy-git

davidovitch commented on 2016-06-05 11:04

@willemw: I missed that pyqt5 has qt5-webengine as a make dep. Must have mixed something up, because you are right, I can run spyder(3)-git without qt5-webengine.

willemw commented on 2016-06-05 10:21

@davidovitch. What breaks? How to check this?
Is qt5-webengine really additional dependency of python-qtpy-git? I only see qt5-webengine as a make dependency of pyqt5. This means qt5-webengine is built into pyqt5?

davidovitch commented on 2016-06-05 09:30

Initially, spyder-git broke when python-pyqt5 was upgraded to 5.6.0. Now qt5-webengine is an additional dependency of python-qtpy-git. Requires the latest changes from both spyder and qtpy. See also

willemw commented on 2016-04-25 06:39

The nbconvert error/warning for spyder (python 3 version) has been fixed.

flocke commented on 2016-04-21 10:34

I opened a bug report for community/jupyter to add entrypoints as dependency:

For the time being you can install entrypoints manually as user to fix the warning: pip3 install --user entrypoints

willemw commented on 2016-04-18 16:20

Nbconvert for python 3 is in package community/jupyter, but seems broken (same error as
>>> import nbconvert
Traceback (most recent call last):
ImportError: No module named 'entrypoints'

Nbconvert for python 2 seems to be missing (in the community repo).

contrebasse commented on 2016-04-18 15:02

It now needs the package nbconvert, but I didn't find it as a package for arch linux.

willemw commented on 2016-01-25 19:34

@flying-sheep: Thanks. Updated.