Package Details: spyder-git 5.0.5.r360.gd829e6db6-1

Git Clone URL: https://aur.archlinux.org/spyder-git.git (read-only, click to copy)
Package Base: spyder-git
Description: The Scientific Python Development Environment
Upstream URL: https://www.spyder-ide.org/
Licenses: MIT
Conflicts: spyder, spyder3-git
Provides: spyder
Replaces: spyder3-git
Submitter: willemw
Maintainer: willemw
Last Packager: willemw
Votes: 24
Popularity: 0.018695
First Submitted: 2015-02-24 08:52
Last Updated: 2021-07-10 14:42

Dependencies (47)

Required by (5)

Sources (1)

Pinned Comments

willemw commented on 2020-08-05 07:20

Note:

Some dependencies may need to be downgraded.

Alternatively, try to edit the requirements file ("requirements/conda.txt" in the source files or "requires.txt" in the installed files).

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

willemw commented on 2018-01-09 09:28

@j_4321: Thanks. Updated.

j_4321 commented on 2018-01-09 08:54

I have just built spyder3-git-3.2.6.r1140.gd0f826592 and when I launched it I got a "ModuleNotFoundError: No module named 'cloudpickle'". So I think that python-cloudpickle (https://aur.archlinux.org/packages/python-cloudpickle/) should be added to the dependencies.

willemw commented on 2017-03-27 16:54

@frankscasket: I think that is a bug in python-qtawesome. It should depend on python-qtpy. See https://github.com/spyder-ide/qtawesome.

Anonymous comment on 2017-03-27 16:40

Thanks for this. In addition, I needed to install the package python-qtpy.

willemw commented on 2016-12-17 07:44

@LeftyAce: Have you tried building without any old build files present?

LeftyAce commented on 2016-12-17 05:57

I'm getting the following error during the build process, any ideas?

Running Sphinx v1.5
Traceback (most recent call last):
File "setup.py", line 306, in <module>
setup(**setup_args)
File "/usr/lib/python2.7/distutils/core.py", line 151, in setup
dist.run_commands()
File "/usr/lib/python2.7/distutils/dist.py", line 953, in run_commands
self.run_command(cmd)
File "/usr/lib/python2.7/distutils/dist.py", line 972, in run_command
cmd_obj.run()
File "/usr/lib/python2.7/distutils/command/build.py", line 127, in run
self.run_command(cmd_name)
File "/usr/lib/python2.7/distutils/cmd.py", line 326, in run_command
self.distribution.run_command(command)
File "/usr/lib/python2.7/distutils/dist.py", line 972, in run_command
cmd_obj.run()
File "setup.py", line 176, in run
setup_command.BuildDoc.run(self)
File "/usr/lib/python2.7/site-packages/sphinx/setup_command.py", line 180, in run
handle_exception(app, self, exc, sys.stderr)
UnboundLocalError: local variable 'app' referenced before assignment

willemw commented on 2016-08-31 16:41

@contrebasse: Thanks. Improved the pep8 patch.

contrebasse commented on 2016-08-31 12:24

Sed doesn't find this file spyder/spyderlib/utils/codeanalysis.py to patch for pycodestyle instead of pep8.

willemw commented on 2016-08-10 06:16

This package depends on python2-pyqt5, which should pull in all the required qt5 dependencies (qt5-base).

spdrfall commented on 2016-08-10 01:03

I have to install qt5 group package (34 members) to get this to work. Should qt5 (or the exact packages required, that are not listed as deps) be added to dependencies?