Package Details: spigot 1.15.2+b108-1

Git Clone URL: https://aur.archlinux.org/spigot.git (read-only, click to copy)
Package Base: spigot
Description: High performance Minecraft server implementation
Upstream URL: https://www.spigotmc.org/
Keywords: craftbukkit games minecraft minecraft-server
Licenses: LGPL
Conflicts: bukkit, craftbukkit, spigot-patcher
Provides: bukkit=1.15.2, craftbukkit=1.15.2, minecraft-server=1.15.2
Submitter: Schala
Maintainer: edh
Last Packager: edh
Votes: 25
Popularity: 0.000668
First Submitted: 2013-10-09 23:27
Last Updated: 2020-01-25 13:32

Dependencies (11)

Required by (8)

Sources (6)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 Next › Last »

wyre commented on 2017-02-27 13:38

when I run again "makepkg -sfi" spigot package doesn't build the last spigot git version. I'm 1 version behind.

Schala commented on 2017-02-27 04:06

Yeah, I too, use jdk8.

lightninjay commented on 2017-02-26 20:55

@Gaesthy

I was having the same issue you are having. It seems as though Jdk7 is having problems connecting to their git. I loaded Jdk8 instead and it seems to be successfully cloning the directories now.

Perhaps give that a shot?

Gaesthy commented on 2017-02-23 23:20

Hi,
I can't install Spigot, can somebody help me?

Loading BuildTools version: git-BuildTools-8aa3a22-59 (#59)
BuildTools
unconfigured@null.spigotmc.org
Starting clone of https://hub.spigotmc.org/stash/scm/spigot/bukkit.git to Bukkit
Exception in thread "main" org.eclipse.jgit.api.errors.TransportException: https://hub.spigotmc.org/stash/scm/spigot/bukkit.git: cannot open git-upload-pack
at org.eclipse.jgit.api.FetchCommand.call(FetchCommand.java:135)
at org.eclipse.jgit.api.CloneCommand.fetch(CloneCommand.java:202)
at org.eclipse.jgit.api.CloneCommand.call(CloneCommand.java:135)
at org.spigotmc.builder.Builder.clone(Builder.java:645)
at org.spigotmc.builder.Builder.main(Builder.java:179)
Caused by: org.eclipse.jgit.errors.TransportException: https://hub.spigotmc.org/stash/scm/spigot/bukkit.git: cannot open git-upload-pack
at org.eclipse.jgit.transport.TransportHttp.connect(TransportHttp.java:510)
at org.eclipse.jgit.transport.TransportHttp.openFetch(TransportHttp.java:288)
at org.eclipse.jgit.transport.FetchProcess.executeImp(FetchProcess.java:136)
at org.eclipse.jgit.transport.FetchProcess.execute(FetchProcess.java:122)
at org.eclipse.jgit.transport.Transport.fetch(Transport.java:1179)
at org.eclipse.jgit.api.FetchCommand.call(FetchCommand.java:128)
... 4 more
Caused by: javax.net.ssl.SSLException: java.security.ProviderException: java.security.InvalidKeyException: EC parameters error
at sun.security.ssl.Alerts.getSSLException(Alerts.java:208)
at sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1914)
at sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1872)
at sun.security.ssl.SSLSocketImpl.handleException(SSLSocketImpl.java:1855)
at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1376)
at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1353)
at sun.net.www.protocol.https.HttpsClient.afterConnect(HttpsClient.java:559)
at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:185)
at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1348)
at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:468)
at sun.net.www.protocol.https.HttpsURLConnectionImpl.getResponseCode(HttpsURLConnectionImpl.java:338)
at org.eclipse.jgit.transport.http.JDKHttpConnection.getResponseCode(JDKHttpConnection.java:98)
at org.eclipse.jgit.util.HttpSupport.response(HttpSupport.java:190)
at org.eclipse.jgit.transport.TransportHttp.connect(TransportHttp.java:461)
... 9 more
Caused by: java.security.ProviderException: java.security.InvalidKeyException: EC parameters error
at sun.security.pkcs11.P11Key$P11ECPublicKey.getEncodedInternal(P11Key.java:1024)
at sun.security.pkcs11.P11Key.equals(P11Key.java:158)
at java.util.ArrayList.indexOf(ArrayList.java:298)
at java.util.ArrayList.contains(ArrayList.java:281)
at sun.security.validator.PKIXValidator.engineValidate(PKIXValidator.java:239)
at sun.security.validator.Validator.validate(Validator.java:260)
at sun.security.ssl.X509TrustManagerImpl.validate(X509TrustManagerImpl.java:326)
at sun.security.ssl.X509TrustManagerImpl.checkTrusted(X509TrustManagerImpl.java:231)
at sun.security.ssl.X509TrustManagerImpl.checkServerTrusted(X509TrustManagerImpl.java:126)
at sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1459)
at sun.security.ssl.ClientHandshaker.processMessage(ClientHandshaker.java:213)
at sun.security.ssl.Handshaker.processLoop(Handshaker.java:961)
at sun.security.ssl.Handshaker.process_record(Handshaker.java:897)
at sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:1033)
at sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1342)
at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1369)
... 18 more
Caused by: java.security.InvalidKeyException: EC parameters error
at sun.security.ec.ECParameters.getAlgorithmParameters(ECParameters.java:284)
at sun.security.ec.ECPublicKeyImpl.<init>(ECPublicKeyImpl.java:59)
at sun.security.pkcs11.P11Key$P11ECPublicKey.getEncodedInternal(P11Key.java:1021)
... 33 more
Caused by: java.security.NoSuchProviderException: no such provider: SunEC
at sun.security.jca.GetInstance.getService(GetInstance.java:83)
at sun.security.jca.GetInstance.getInstance(GetInstance.java:206)
at java.security.Security.getImpl(Security.java:697)
at java.security.AlgorithmParameters.getInstance(AlgorithmParameters.java:199)
at sun.security.ec.ECParameters.getAlgorithmParameters(ECParameters.java:279)
... 35 more
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build spigot.
==> Restart building spigot ? [y/N]
==> -------------------------------

wyre commented on 2017-02-15 00:39

And what is spigot-backup.timer?

Schala commented on 2017-02-14 00:52

I don't use it. It's optional anyway.

wyre commented on 2017-02-13 02:03

Is it necessary enable spigot-backup.service? because it makes systemd slower.

Schala commented on 2016-12-21 20:56

Odd. I explicitly put it to get 1.11.1, but oh well. updating

Jacuzzi commented on 2016-12-21 13:19

I have an error while installing the latest version...

Success! Everything compiled successfully. Copying final .jar files now.
Copying craftbukkit-1.11.2-R0.1-SNAPSHOT.jar to /home/jacuzzi/.cache/pacaur/spigot/src/.
- Saved as craftbukkit-1.11.2.jar
Copying spigot-1.11.2-R0.1-SNAPSHOT.jar to /home/jacuzzi/.cache/pacaur/spigot/src/.
- Saved as spigot-1.11.2.jar
==> Entering fakeroot environment...
==> Starting package()...
install: cannot stat 'spigot-1.11.1.jar': No such file or directory
==> ERROR: A failure occurred in package().
Aborting...

Schala commented on 2016-07-12 23:50

I did that for backwards compatibility with Craftbukkit