Package Details: spflashtool-bin 5.1916-1

Git Clone URL: https://aur.archlinux.org/spflashtool-bin.git (read-only)
Package Base: spflashtool-bin
Description: SP Flash Tool is an application to flash your MediaTek (MTK) SmartPhone.
Upstream URL: http://spflashtools.com/category/linux
Licenses: unknown
Conflicts: spflashtool
Provides: spflashtool
Submitter: Omar007
Maintainer: Omar007
Last Packager: Omar007
Votes: 25
Popularity: 0.050410
First Submitted: 2016-05-21 15:48
Last Updated: 2019-06-21 10:10

Latest Comments

1 2 3 4 Next › Last »

RonnyD commented on 2019-10-10 20:43

I am getting the following error:

libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
QObject::moveToThread: Cannot move objects with a parent
support_dl_cert_to_storage: 0
comboTimeout index(3) saved.
/usr/bin/spflashtool: line 3:  3133 Segmentation fault      (core dumped) /opt/spflashtool/flash_tool "${@}"

Am I missing something?

azurata commented on 2019-06-22 19:59

@Omar007 I'm doing this way so I don't need to compile/install qtwebkit. Program works the same way, why compile qtwebkit from source ¯\_(ツ)_/¯

Omar007 commented on 2019-06-22 19:32

@azurata; I could already see that. But I can't see why you would do so in the first place? For what reason are you doing this?

azurata commented on 2019-06-22 17:11

@Omar007 What I did was replace the need of qtwebkit dependency by using the lib files libQtWebKit.so.4 and libphonon.so.4 already included in the file SP_Flash_Tool_v5.1916_Linux.zip

This is my patch:

--- <PKGBUILD>
+++ <PKGBUILD>
@@ -8,7 +8,7 @@
 arch=('x86_64')
 url="http://spflashtools.com/category/linux"
 license=('unknown')
-depends=('qtwebkit')
+depends=('qt4')
 makedepends=('gendesk')
 provides=('spflashtool')
 conflicts=('spflashtool')
@@ -45,6 +45,9 @@
 package() {
    local folderName="SP_Flash_Tool_v${pkgver}_Linux"

+   # qtwebkit libraries
+   install -Dm644 "${srcdir}/${folderName}/lib/lib"{QtWebKit,phonon}.so.4 -t "${pkgdir}/opt/${_pkgname}/"
+
    # Clean files we do not need
    rm "${srcdir}/${folderName}/flash_tool.sh"
    rm -r "${srcdir}/${folderName}/bin"
@@ -52,7 +55,7 @@
    rm -r "${srcdir}/${folderName}/plugins"

    # Install remaining files
-   install -Dm644 -t "${pkgdir}/opt/${_pkgname}/" "${srcdir}/${folderName}/"*
+   install -Dm644 "${srcdir}/${folderName}/"* "${pkgdir}/opt/${_pkgname}/"

    # Mark the binary as executable and install the shell file created in prepare()
    chmod +x "${pkgdir}/opt/${_pkgname}/flash_tool"

Omar007 commented on 2019-06-22 13:01

@azurata: I have no idea what you're trying to do there but it's also completely unrelated to what gsavchuk is saying.

This has been build and run with qt4 4.8.7-30 and qtwebkit 2.3.4-7 in a clean chroot. It is running fine against these versions. If you're doing other stuff on your system (overriding libraries, building dependencies with components disabled, bypassing pacman with make install, partial updates, ...), that's up to you but so is fixing any problems you may have.

If you can reproduce this on a clean setup then please let me know and I'll take another look at it.

azurata commented on 2019-06-21 22:09

@Omar007 I tested an alternative to the qtwebkit dependency and it works.

(...)
local folderName="SP_Flash_Tool_v${pkgver}_Linux"

cp "${srcdir}/${folderName}/lib/lib"{QtWebKit,phonon}.so.4 "${srcdir}/${folderName}/"

# Clean files we do not need
rm "${srcdir}/${folderName}/flash_tool.sh"
rm -r "${srcdir}/${folderName}/bin"
rm -r "${srcdir}/${folderName}/lib"
rm -r "${srcdir}/${folderName}/plugins"
(...)

Omar007 commented on 2019-06-21 09:47

@gsavchuck: In qt4-4.8.7-30.

$ pacman -Fs libQtXmlPatterns.so.4
qt4 4.8.7-30
    usr/lib/libQtXmlPatterns.so.4

You might want to verify the integrity of your qt4 installation and ensure it isn't broken.

gsavchuk commented on 2019-06-18 19:33

Installed this package alongside with qt4-4.8.7-30. When I try to launch it I get the error:

/opt/spflashtool/flash_tool: error while loading shared libraries: libQtXmlPatterns.so.4: cannot open shared object file: No such file or directory

I think this library was included in past releases of qt4. Where am I supposed to get the missing dependency now?

azurata commented on 2019-03-19 12:51

For anyone with problems stuck at "Trying to sync with the target...", try stopping modemmanager "systemctl stop ModemManager.service"

dimich commented on 2019-02-27 07:26

If anyone have problem with validity check while updating with aurman try to remove ~/.cache/aurman/spflashtool-bin/SP_Flash_Tool_v5.1844_Linux.zip