Package Details: spek-wxgtk3 0.8.3-1

Git Clone URL: https://aur.archlinux.org/spek-wxgtk3.git (read-only, click to copy)
Package Base: spek-wxgtk3
Description: An acoustic spectrum analyser (compiled against wxGtk3 and latest ffmpeg)
Upstream URL: http://spek.cc/
Licenses: GPL3
Conflicts: spek
Provides: spek
Submitter: teddybeermaniac
Maintainer: teddybeermaniac
Last Packager: teddybeermaniac
Votes: 2
Popularity: 0.61
First Submitted: 2021-01-30 10:17
Last Updated: 2021-01-30 10:17

Latest Comments

SonicoXD commented on 2021-02-20 20:11

You're right, it compiles properly now. Thanks for the heads-up!

teddybeermaniac commented on 2021-02-04 20:47

Hi, I Googled the error from your log and I found out that it's caused by a change in autoconf 2.70. I use Manjaro which still has 2.69, that's why compilation works for me. I found a discussion about this error when compiling another project - https://lists.gnu.org/archive/html/autoconf/2021-01/msg00006.html and the change was reverted in 2.71 (http://git.savannah.gnu.org/gitweb/?p=autoconf.git;a=log;h=refs/tags/v2.71 4th commit from the top) which is already in Arch's testing repository.

SonicoXD commented on 2021-02-01 19:47

The package fails to build, trying to install it using yay.

==> Starting build()... autoreconf: export WARNINGS= autoreconf: Entering directory '.' autoreconf: running: intltoolize --automake --copy --force autoreconf: running: aclocal --force autoreconf: configure.ac: tracing configure.ac: error: AM_GNU_GETTEXT_VERSION or AM_GNU_GETTEXT_REQUIRE_VERSION is used, but not AM_GNU_GETTEXT autoreconf: configure.ac: not using Libtool autoreconf: running: intltoolize --copy --force autoreconf: configure.ac: not using Gtkdoc autoreconf: running: /usr/bin/autoconf --force autoreconf: running: /usr/bin/autoheader --force autoreconf: running: automake --add-missing --copy --force-missing configure.ac:15: installing './config.guess' configure.ac:15: installing './config.sub' configure.ac:4: installing './install-sh' configure.ac:4: installing './missing' src/Makefile.am: installing './depcomp' parallel-tests: installing './test-driver' autoreconf: './install-sh' is updated autoreconf: './config.sub' is updated autoreconf: './config.guess' is updated autoreconf: Leaving directory '.' ==> ERROR: A failure occurred in build(). Aborting... error making: spek-wxgtk3

This is solved by running ./configure inside the spek-0.8.3 before make.