Package Details: spectral-git 218.r530.gbb0f801-1

Git Clone URL: https://aur.archlinux.org/spectral-git.git (read-only)
Package Base: spectral-git
Description: Glossy cross-platform client for Matrix
Upstream URL: https://gitlab.com/b0/spectral
Licenses: GPL3
Submitter: bergentroll
Maintainer: bergentroll
Last Packager: bergentroll
Votes: 2
Popularity: 0.506832
First Submitted: 2019-02-15 07:58
Last Updated: 2019-08-21 06:12

Latest Comments

Scrumplex commented on 2019-07-17 00:08

I think having a shared library makes sense, as there may be more matrix clients written in C++/Qt in the future. I am interested in writing one myself, which is why I packaged it in the first place.

Sadly I can't really maintain Spectral myself, as I don't use it either, but thanks for the offer :D

bergentroll commented on 2019-07-16 08:11

Scrumplex, thank you! Do you think adding libQuotient as a shared library is actually a good idea? There is significantly more object code and need to build another one package.

Also if you want to co-mantain or own the package, please let me know, because I am not using Spectral for now.

Scrumplex commented on 2019-07-15 17:11

I packaged up libQuotient today. To utilize it as a shared library, first add "libquotient" as a dependency and add "USE_SYSTEM_QMATRIXCLIENT=true" as a parameter to qmake.

bergentroll commented on 2019-03-02 05:59

Strit, thank you, fixed!

Strit commented on 2019-03-01 20:36

This package needs git to be added to makedepends=(). It can't retrieve the source otherwise. And qt5-multimedia to depends=() list.