Package Details: spacenavd 0.7.1-1

Git Clone URL: https://aur.archlinux.org/spacenavd.git (read-only, click to copy)
Package Base: spacenavd
Description: The spacenav project provides a free, compatible alternative, to the proprietary 3Dconnexion device driver and SDK, for their 3D input devices (called 'space navigator', 'space pilot', 'space traveller', etc).
Upstream URL: http://spacenav.sourceforge.net/
Licenses: GPL
Provides: spacenavd
Submitter: jaham
Maintainer: dkcampbell
Last Packager: dkcampbell
Votes: 13
Popularity: 0.44
First Submitted: 2009-01-01 19:01
Last Updated: 2020-06-04 00:37

Latest Comments

1 2 Next › Last »

dkcampbell commented on 2020-07-05 16:16

@And1G, thanks for the feedback. I'll have time this coming Friday to look at this. I'll get it squared away.

And1G commented on 2020-07-02 07:16

Building in a clean chroot results in an error for me:

gcc -pedantic -Wall -g -O2 -fno-strict-aliasing -fcommon -I./src -I/usr/local/include -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -c src/client.c -o src/client.o In file included from src/client.c:22: src/client.h:25:10: fatal error: X11/Xlib.h: No such file or directory 25 | #include <X11/Xlib.h> | ^~~~~~~~~~~~ compilation terminated. make: *** [Makefile:31: src/client.o] Error 1

Consider adding makedepends=("libx11")

dkcampbell commented on 2020-06-04 00:22

I've updated the package to pull in version 0.7.1, fixing the build issues with GCC 10. @bwrsandman I incorporated your comments into the PKGBUILD as well.

demizer commented on 2020-06-03 17:14

Hey all, I disowned this package. Don't really have time to maintain it properly.

bwrsandman commented on 2020-06-03 10:28

It's not necessary to add || return 1 on every line. If a line fails in makepkg, the build stops.

dkcampbell commented on 2020-05-22 15:45

@mazieres, yes I agree. That was one of the fixes in the release notes for spacenavd. My patch was to upgrade the PKGBUILD to pull in 0.7.1 instead of 0.7.

Looking forward to the official PKGBUILD being updated to 0.7.1!

mazieres commented on 2020-05-22 01:36

@dkcampbell Version 0.7.1 compiles fine for me with gcc 10. Just upgrade from 0.7 to 0.7.1.

dkcampbell commented on 2020-05-22 00:42

I couldn't get this to build. Based on release notes, probably a compatibility issue with gcc-10. Here are the changes I made to the PKGBUILD to get it to work on my computer: https://paste.sr.ht/blob/74c21d0fafe3d45f4a299c42f740195308c71e86

demizer commented on 2020-05-19 19:53

@mazieres, will do once I update this package today or tomorrow.

mazieres commented on 2020-05-19 18:45

Consider moving /etc/systemd/system/spacenavd.service to /usr/lib/systemd/system/spacenavd.service, since that's where packages generally install service files, vs. user-edited files under /etc.