Package Details: soqt-git r2135.2f85c94b-1

Git Clone URL: https://aur.archlinux.org/soqt-git.git (read-only, click to copy)
Package Base: soqt-git
Description: The glue between Coin and Qt
Upstream URL: https://github.com/coin3d/soqt
Licenses: GPL
Conflicts: soqt
Provides: soqt
Submitter: micwoj92
Maintainer: yar (notfood)
Last Packager: micwoj92
Votes: 1
Popularity: 0.000000
First Submitted: 2021-05-03 01:56
Last Updated: 2021-05-03 01:56

Required by (6)

Sources (1)

Latest Comments

micwoj92 commented on 2021-05-03 01:58

Forgot to upload, just done it.

micwoj92 commented on 2021-03-10 04:27

I got some free time and made soqt-git PKGBUILD and will upload it this week. @yar @notfood wanna get added as co-maintainers there?

micwoj92 commented on 2020-09-16 07:40

But is there at least mirror somewhere? I see you added me as co maintainer. But if no hg mirrors can be found then this package should be deleted .

yar commented on 2020-09-16 06:48

Upstream has stopped developing soqt, in favor of Quarter. I recommend people switch to that: https://aur.archlinux.org/packages/quarter/

micwoj92 commented on 2020-09-08 01:35

Bitbucket no longer hosts mercurial repositories, could you update this package?

notfood commented on 2019-01-02 05:09

@Ennoia

It needs coin-hg, you need to replace the following lines under build cd "${srcdir}/${pkgname}" ./configure ...

with cd "${srcdir}/${pkgname}"/build cmake .. -DCMAKE_INSTALL_LIBDIR=/usr/lib

and the following under package cd "${srcdir}/${pkgname}" with cd "${srcdir}/${pkgname}"/build

Remove qt4 in depends and it will produce a working package that uses qt5.

Ennoia commented on 2018-10-26 13:50

Hi, Is there a way for soqt-hg to use qt5 ? It seems supported at least since juny 2016 ? Something with the --with-qt option ? https://bitbucket.org/Coin3D/soqt/commits/e8310fe21c1bf8fd80b7f93f1b69cffb41ee595b