Package Details: sogo2 2.3.23-1

Git Clone URL: https://aur.archlinux.org/sogo2.git (read-only, click to copy)
Package Base: sogo2
Description: groupware server built around OpenGroupware.org (OGo) and the SOPE application server
Upstream URL: http://www.sogo.nu/
Licenses: GPL
Conflicts: sogo, sogo-openchange, sogo2-openchange
Provides: sogo-activsync, sogo2-activesync
Replaces: sogo-activesync, sogo2-activesync
Submitter: DJ_L
Maintainer: deons
Last Packager: deons
Votes: 14
Popularity: 0.000000
First Submitted: 2016-04-26 03:48
Last Updated: 2018-01-21 02:12

Dependencies (18)

Required by (0)

Sources (4)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

kvtb commented on 2015-04-16 17:36

Thanks for this package. Small question: in the PKGBUILD, would it be possible to use the pkgver variable in the depends and in the sources to avoid duplication of the sogo version?
like
depends=(sogo=${pkgver} 'libwbxml')
?
Thanks

DJ_L commented on 2015-03-25 06:01

As usual. Development continues. 2.2.17 is out. Looks like a lot of AS fixes. Did you get a chance to review my suggested changes regarding the default Apache config file? Additionally, I've added the logratate configuration too:

backup=(etc/sogo/sogo.conf etc/httpd/conf/extra/SOGo.conf)
...
install -D -m 0644 ${srcdir}/SOGo-${pkgver}/Apache/SOGo.conf ${pkgdir}/etc/httpd/conf/extra/SOGo.conf
...
install -D -m 0644 ${srcdir}/SOGo-${pkgver}/Scripts/logrotate ${pkgdir}/etc/logrotate.d/SOGo

HTH

kwirkie commented on 2015-03-06 22:15

Ack...sorry for the delay. Thought I'd already uploaded this. Thanks for heads up DJ_L :-)

DJ_L commented on 2015-01-23 06:02

2.2.14 is out. These guys don't slow down!

DJ_L commented on 2015-01-13 01:31

2.2.13, still straight version and md5 change.

DJ_L commented on 2014-12-18 04:10

AFAIK, straight version update

pkgver=2.2.11a
depends=('sope=2.2.11'
md5sums=('30995a8bb5251a02302fe7161aa14566'

Plus suggestion below.

DJ_L commented on 2014-12-16 21:01

It's just using the regular search path. IIUC, it gets loaded via mod_wsgi so you'd have set LD_PRELOAD or LD_LIBRARY_PATH in the apache init script (or fix the library search path some other way (ie: create the so.X.Y link in /usr/lib and run ldconfig)).

tritron commented on 2014-12-16 01:34

Well I accidentally flagged it out of date.
Well libSOGo.so.2 in /usr/lib is causing problem it is linked to
../GNUstep/Frameworks/SOGo.framework/Versions/Current/sogo/libSOGo.so.2


it seems to be in /usr/lib/sogo and /usr/lib but it cant be loadeded for some reason. I cp -a ../GNUstep/Frameworks/SOGo.framework/Versions/Current/sogo/lib* /usr/lib/
and that get ocsmanafer started
I wonder why is ocsmanager looking for libSOGo.so. in /usr/lib instead /usr/lib/sogo ?
I get this error alsp
Dec 15 17:32:33 samba [27851]: [ERROR] [so-product-registry] failed to load product Appointments required by SOGoBackend

DJ_L commented on 2014-12-15 20:47

I don't see a new version on sogo.nu. ? As to the error, I don't see this either. I've got it running live. Did the sope and sogo package upgrades install correctly? Need a bit more info to figure out what is wrong. What is the result of ldd on libSOGo.so.2?

tritron commented on 2014-12-15 18:38

I am getting
Unable to open /usr/lib/mapistore_backends/libMAPIStoreSOGo.so: libSOGo.so.2: cannot open shared object file: No such file or direc
Dec 13 10:52:05 zafire paster[4068]: Unable to open /usr/lib/mapistore_backends/libMAPIStoreSOGo.so.1.0.0: libSOGo.so.2: cannot open shared object file: No such file or
Dec 13 10:52:05 zafire paster[4068]: Unable to open /usr/lib/mapistore_backends/libMAPIStoreSOGo.so.1: libSOGo.so.2: cannot open shared object file: No such file
I think you need to install libs in /usr/lib/sogo
after moving to sogo folder I get this
params.c:pm_process() - Processing configuration file "/etc/samba/smb.conf"
Dec 15 11:24:55 zafire paster[5250]: [mapistore_init:87]: Storage backend initialization failed