Package Details: sogo 5.0.1-1

Git Clone URL: https://aur.archlinux.org/sogo.git (read-only, click to copy)
Package Base: sogo
Description: groupware server built around OpenGroupware.org (OGo) and the SOPE application server
Upstream URL: http://www.sogo.nu/
Licenses: GPL
Replaces: sogo2
Submitter: DJ_L
Maintainer: deons
Last Packager: deons
Votes: 11
Popularity: 0.124625
First Submitted: 2016-05-05 01:05
Last Updated: 2020-10-22 16:05

Dependencies (20)

Required by (0)

Sources (4)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

DJ_L commented on 2016-12-14 01:04

Updated to 3.2.3. 2x versions in a few.

DJ_L commented on 2016-12-14 00:47

Most likely your gnustep-make package is slightly misconfigured. An update a few months ago made the configuration file an actual configuration file in the PKGBUILD and likely it didn't get updated. I'm referring to this bug: https://bugs.archlinux.org/task/50135

Just make sure that GNUSTEP_NETWORK_ADMIN_TOOLS=/usr/bin and GNUSTEP_LOCAL_ADMIN_TOOLS=/usr/bin in /etc/GNUstep/GNUstep.conf. Nothing should be referring to /sbin or /usr/sbin (they don't actually exist and dependent packages use these values). I'll be updating this package to 3.2.3 in just a few minutes anyway, but check those values and see if that's the problem.

travnick commented on 2016-12-13 18:59

error: failed to commit transaction (conflicting files)
sogo: /usr/sbin exists in filesystem

DJ_L commented on 2016-10-08 04:39

3.2.0 is out and seems to work. I have it installed, but it is causing SIG11 when switching screens on current Chromium. Still investigating. Holding update until resolved.

DJ_L commented on 2016-08-11 23:55

Updated to 3.1.5.

DJ_L commented on 2016-08-11 23:26

mober: at best guess, you need to update gnustep-make to 2.6.8-2 (or presumably -3).

EDIT: You probably already did this, but didn't update the config file. There should be an /etc/GNUstep/GNUstep.conf.pacnew file, which needs to replace the /etc/GNUstep/GNUstep.conf (if you've never modified that file). If you have modifications to the GNUstep configuration, change all instances of /usr/sbin to /usr/bin as it was incorrect in versions prior to gnustep-make-2.6.8-2.

If this isn't it, I'll try and get a first hand look at it a bit later tonight or tomorrow as 3.1.5 was released today.

mober commented on 2016-08-11 10:45

error: failed to commit transaction (conflicting files)
sogo: /usr/sbin exists in filesystem
sogo: /usr/sbin/sogo-ealarms-notify exists in filesystem
sogo: /usr/sbin/sogo-slapd-sockd exists in filesystem
sogo: /usr/sbin/sogo-tool exists in filesystem
sogo: /usr/sbin/sogod exists in filesystem
Errors occurred, no packages were upgraded.

DJ_L commented on 2016-08-06 06:15

GNUStep-Make has been fixed, bumped release to remove unneeded GNUSTEP_SYSTEM_ADMIN_TOOLS parameter.

DJ_L commented on 2016-07-29 17:21

Looks like this is fixed in gnustep-make-2.6.8-2.

DJ_L commented on 2016-07-23 19:40

Okay, so gnustep-make-2.6.8-1 is broken. So was gnustep-make-2.6.7-1, but it happened to work with this package. The quick fix is:

# sed 's@/usr/sbin@/usr/bin@' -i.bak /usr/GNUstep/GNUstep.conf

I've created a bug (with patch) for the package at

https://bugs.archlinux.org/task/50135