Package Details: snapper-git 0.4.5.git.1328.13fb9c1-1

Git Clone URL: https://aur.archlinux.org/snapper-git.git (read-only)
Package Base: snapper-git
Description: A tool for managing BTRFS and LVM snapshots. It can create, diff and restore snapshots and provides timelined auto-snapping.
Upstream URL: http://snapper.io
Licenses: GPL2
Conflicts: snapper
Provides: snapper
Submitter: teekay
Maintainer: Batou
Last Packager: NicoHood
Votes: 25
Popularity: 0.000083
First Submitted: 2012-01-31 19:54
Last Updated: 2017-04-25 17:55

Required by (4)

Sources (1)

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 Next › Last »

Anonymous comment on 2012-10-22 18:59

makepkg is failing for me on a fresh install... I've got boost 1.50.0-2 from extra.

/usr/bin/ld: cannot find -lboost_thread-mt
collect2: error: ld returned 1 exit status
make[2]: *** [libsnapper.la] Error 1
make[2]: Leaving directory `/home/matt/Downloads/snapper-git/src/snapper-build/snapper'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/matt/Downloads/snapper-git/src/snapper-build'
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
Aborting...

It looks like openSUSE has boost 1.49 in it's repos, but downgrading to that didn't help. I've tried softlinking libboost_thread.a and/or libboost_thread.so with an -mt suffix, but no joy there either.

Thanks,
Matt

teekay commented on 2012-06-20 12:32

@srf21c: install base-devel. See https://wiki.archlinux.org/index.php/AUR#Getting_started

sysfu commented on 2012-06-19 23:19

makepkg fails for me here:

==> Starting build...
Cloning into '/home/seth/snapper-git/src/snapper-build'...
done.
/home/seth/snapper-git/PKGBUILD: line 49: aclocal: command not found
==> ERROR: A failure occurred in build().
Aborting...

teekay commented on 2012-04-28 10:17

Thanks. Updated accordingly.

skydrome commented on 2012-04-27 02:26

repo is at https://github.com/opensuse/snapper now

teekay commented on 2012-02-29 11:29

Update: removed blocxx-svn depend - it's not needed anymore.
http://gitorious.org/opensuse/snapper/commit/79a08d3dae572ee4fbad0d7e5235664e14469656

teekay commented on 2012-02-12 19:27

@crabman: recompile blocxx-svn

crabman commented on 2012-02-12 19:11

broken since latest pcre update

teekay commented on 2012-02-08 08:33

Changed dependency to blocxx-svn as there is no blocxx available currently, and added subversion to blocxx-svn's makedepends.
Thanks @rewind.

Anonymous comment on 2012-02-07 17:19

blocxx is not available, there is blocxx-svn, but needs subversion dependency.
Thanks.