Package Details: snapd 2.51.1-1

Git Clone URL: https://aur.archlinux.org/snapd.git (read-only, click to copy)
Package Base: snapd
Description: Service and tools for management of snap packages.
Upstream URL: https://github.com/snapcore/snapd
Licenses: GPL3
Conflicts: snap-confine
Submitter: Barthalion
Maintainer: bboozzoo (zyga)
Last Packager: bboozzoo
Votes: 163
Popularity: 4.70
First Submitted: 2018-01-07 17:37
Last Updated: 2021-06-28 07:58

Pinned Comments

bboozzoo commented on 2018-10-25 11:56

2.36 is the first release with AppArmor enabled by default on Arch.

If you do not have AppArmor enabled at boot there should be no functional changes visible.

If you wish to use snaps with Apparmor, first make sure that Apparmor is enabled during boot, see https://wiki.archlinux.org/index.php/AppArmor for details. After upgrading the package, you need to do the following steps:

  • Reload the profiles: systemctl restart apparmor.service
  • Restart snapd: systemctl restart snapd.service
  • Load profiles for snaps: systemctl enable --now snapd.apparmor.service

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 ... Next › Last »

bboozzoo commented on 2020-07-16 05:25

@bittin can you try again? There was some delay in publishing tarballs in the releases page. This also overlapped with some unexpected github downtime.

bittin commented on 2020-07-15 12:33

The download from Github does not work

ZombB commented on 2020-05-25 21:22

@bboozzoo Thanx, 'export LC_ALL=C' and 'pikaur -S snapd' now did the trick, snapd was installed from AUR and is now working fine!

bboozzoo commented on 2020-05-25 20:04

@ZombB please attach the journal output, preferrably try building it again with LC_ALL=C. Make sure that all packages from base-devel are installed and that build dependencies are installed.

bboozzoo commented on 2020-05-22 10:28

@camilojm patch is part of base-devel which is implicitly expected to be installed when building anything from AUR.

camilojm commented on 2020-05-22 07:54

Sorry, this is the log

Starting prepare () ... -> applying 0001-fontconfig-compat.patch / tmp / trizen-camilo / snapd / PKGBUILD: line 49: patch: command not found ==> Error: An error occurred in prepare (). Abandoning ... :: Unable to build snapd-makepkg exited with code: 4 = >> Try again? [Y / N]:

bboozzoo commented on 2020-05-22 06:03

@camilojm please provide a log.

camilojm commented on 2020-05-21 23:44

Error makinkg snapd i have also LANG=zh_CN.UTF-8 not sure if that is the problem, but i have LANG=en_US.UTF-8 and LANG=es_COL.UTF-8 ass support

bboozzoo commented on 2020-05-19 09:41

@sxyzy1016 thanks, this is useful. I've pushed an update.

sxyzy1016 commented on 2020-05-19 09:30

set LANG=zh_CN.UTF-8 and run into Error making: snapd in check(); set LANG=en_US.UTF-8 and it works fine.