Package Details: smplayer-svn 19.5.0.r9225M-1

Git Clone URL: https://aur.archlinux.org/smplayer-svn.git (read-only, click to copy)
Package Base: smplayer-svn
Description: Media player with built-in codecs that can play virtually all video and audio formats
Upstream URL: https://www.smplayer.info/
Licenses: GPL
Conflicts: smplayer
Provides: smplayer
Submitter: None
Maintainer: 314eter
Last Packager: 314eter
Votes: 142
Popularity: 0.001216
First Submitted: 2008-02-19 15:58
Last Updated: 2019-07-14 13:33

Required by (8)

Sources (1)

Latest Comments

« First ‹ Previous ... 4 5 6 7 8 9 10 11 Next › Last »

Anonymous comment on 2010-12-05 11:28

@syne

What do you learn out of this?

That not all AUR packages are flawless.

You should check each and every one of them, if they are correctly made up to the packaging standards, and not blindly trust them to comply.

Anonymous comment on 2010-12-05 11:23

So, flamelab's package is as it should be.

Anonymous comment on 2010-12-05 11:23

@syne

mplayer-git package is wrong.

If you had read the pacman documentation, you would have known that after pacman 3.x, every package that provides another, has to include in the provides array, specific versions, either with "=" or with ">=".

A very good way to deal with this, if you build a package that provides another, is to always provide the current (latest) version of that stock package that is in extra, at the time you build the package.

So syne, you'd better RTFM next time.



PS: There are many packages, even in the official repos (ie extra) that do not comply to this. That does not mean that they are correct. In fact, they need to be corrected.

flamelab commented on 2010-12-05 11:18

Νο, I don't think I will remove it. I support the official svn versioning of mplayer (the one from [extra] mainly) and, thus, I still use the svn versions in the depends.

syne commented on 2010-12-05 10:05

ok, i give, it's much easier just to remove version number from your pkg.

flamelab commented on 2010-12-03 16:09

Well, there is **workaround**: add

provides=("mplayer-svn=35000") (for example)

in the mplayer*-git package, rebuild it and you will be OK. It wouldn't of course provide *that* particular svn version, but it's *workaround*.

syne commented on 2010-12-03 11:30

does the pkg not work with mplayer versions under 30526? because as you know git-versions don't really match official versions:(
plus, it's probably safe to say that everyone's got a mplayer with version over 30526.

flamelab commented on 2010-11-30 15:04

It doesn't depend on a particular version, it depends on the versions newer that the current one specified in the PKGBUILD (30526 for now, from svn, which is the official).

syne commented on 2010-11-30 10:54

because every time i update it, i have to remember to edit the PKGBUILD. i use mplayer-git, so it would be rather nice if this pkg didn't depend on a particular version of mplayer.

flamelab commented on 2010-10-19 18:12

Why shouldn't it ?