Package Details: slurm-llnl 20.02.3.1-1

Git Clone URL: https://aur.archlinux.org/slurm-llnl.git (read-only, click to copy)
Package Base: slurm-llnl
Description: Simple Linux Utility for Resource Management
Upstream URL: https://www.schedmd.com
Keywords: manager resource system
Licenses: GPL
Submitter: tegenf
Maintainer: edh
Last Packager: edh
Votes: 11
Popularity: 0.001020
First Submitted: 2011-01-28 14:47
Last Updated: 2020-05-22 11:01

Dependencies (19)

Sources (6)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 ... Next › Last »

aorth commented on 2013-08-17 19:45

I've just updated my PKGBUILD for new upstream release (2.6.1). It's in my github repo here:

https://github.com/alanorth/archbuilds/commit/56062595a9a871a3338290718602fa5bc9fe8780

aorth commented on 2013-07-14 19:51

I've just updated my PKGBUILD. Changes include:

- SLURM 2.6.0[0]
- libmysqlclient -> libmariadbclient[1]
- Remove DB libs from depends[2]; technically they're optional (the build system will detect and use them if they're installed)

[0] https://github.com/alanorth/archbuilds/commit/3b1fc4ab7ff1d95a9d754904056587cce0835270
[1] https://github.com/alanorth/archbuilds/commit/48fe6efefcde4a547ba68969f9c28659d9b505e0
[2] https://github.com/alanorth/archbuilds/commit/b2adb5604d46544f3d687172fdb64fe14bc2d0c7

tegenf commented on 2013-06-24 09:43

Ok, sorry for the delay but now I have updated to 2.5.7 using the improvements and updates from aorth. Thank you very much for providing us with the update!

aorth commented on 2013-06-08 19:21

I've updated my version of this package to 2.5.7[0]. If you don't want to clone my whole archbuilds git repo[1] to get this, I've posted a tarball of this package as well[2].

[0] https://github.com/alanorth/archbuilds/commit/defe04a5e54bc0dc2795d6dfd05a0b1f009b5cfb
[1] https://github.com/alanorth/archbuilds
[2] https://copy.com/vGG2TjlxTVOp (md5sum: b1c42fd75225ef8b8fb5f0a468492d1d)

wookietreiber commented on 2013-06-08 13:10

yeah, would be awesome to have these changes incorporated

aorth commented on 2013-06-02 19:29

Ok, I've greatly improved, reorganized and simplified this package:
- move all binaries from /usr/sbin to /usr/bin
- rename service files from slurm*-llnl.service to slurm*.service
- fix the dependencies for slurmdbd (it's sufficient for slurmdbd.service to say "Before=slurmctld.service", which won't affect people who don't use slurmdbd).
- more?!

It's available on my github if you want to take a look at the commit history:

https://github.com/alanorth/archbuilds/tree/master/slurm-llnl

aorth commented on 2013-06-01 07:56

Heads up, you'll need to move /usr/sbin/slurm* to /usr/bin. See Allan's comments regarding finishing the /usr move soon in [testing]:

https://mailman.archlinux.org/pipermail/arch-dev-public/2013-May/025003.html

wookietreiber commented on 2013-05-12 20:56

Please check the package with namcap and fix the issues (RPATH, dependencies, ...).

wookietreiber commented on 2013-04-26 09:08

thx for updating.

is the a reason why you have chosen

http://www.schedmd.com/

over the direct slurm page

http://slurm.schedmd.com/

tegenf commented on 2013-04-26 08:18

* updated to 2.5.6
thx wookietreiber for pointing out the faulty upstream url.