Package Details: slic3r 1.3.0-17

Git Clone URL: https://aur.archlinux.org/slic3r.git (read-only)
Package Base: slic3r
Description: Slic3r is an STL-to-GCODE translator for RepRap 3D printers, aiming to be a modern and fast alternative to Skeinforge.
Upstream URL: http://slic3r.org/
Keywords: 3d-printing
Licenses: GPL
Conflicts: slic3r-git
Provides: slic3r
Submitter: nickoe
Maintainer: nickoe
Last Packager: nickoe
Votes: 49
Popularity: 1.06
First Submitted: 2012-08-26 23:07
Last Updated: 2019-07-02 22:22

Dependencies (25)

Required by (2)

Sources (3)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

dsjstc commented on 2019-10-27 23:21

Requires boost-libs 1.69, which does not exist. The available version at this moment is 1.71.

Can't load '/usr/lib/perl5/5.30/vendor_perl/auto/Slic3r/XS/XS.so' for module Slic3r::XS: libboost_filesystem.so.1.69.0: cannot open shared object file: No such file or directory at /usr/share/perl5/core_perl/XSLoader.pm line 93.

ejona86 commented on 2019-09-16 01:01

It seems the GUI depends on perl-libwww:

$ slic3r --gui
Can't locate LWP/UserAgent.pm in @INC (you may need to install the LWP::UserAgent module) (@INC contains: ...) at /usr/share/perl5/vendor_perl/Slic3r/GUI/Plater.pm line 26.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/Slic3r/GUI/Plater.pm line 26.
Compilation failed in require at /usr/share/perl5/vendor_perl/Slic3r/GUI.pm line 35.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/Slic3r/GUI.pm line 35.
Compilation failed in require at (eval 156) line 1.

nickoe commented on 2019-09-09 10:05

You need to install some of the optional packages

neo2001 commented on 2019-09-09 09:42

I've built this package and now want to start the application showing up in the app menu, but nothing happens? I tried to start "slic3r" in the command line, but I only get a long usage output of all possible options and arguments. Am I doing something wrong?

nickoe commented on 2019-07-02 22:23

@MightyTheJa, yeah, thank you. I missed that. I have updated it, but I didn't bump the pkgrel as there is no change if you already built it.

keenerd commented on 2019-07-02 17:16

MightyTheJa: Use my WIP pkgbuild. Nickoe glossed over most of the required corrections, including the changes to depends and makedepends.

MightyTheJa commented on 2019-07-02 12:14

Wouldn't build without boost,, shouldn't it be on dependency list?

nickoe commented on 2019-07-01 18:41

Ok, thank you for your feedback keenerd. I have now taken time to fix it up. I will push it shortly.

I wonder if it makes sense to move the gui stuff form the optdepends to depends for this package and maybe have a slic3r-nogui package if someone needs that.

keenerd commented on 2019-06-30 20:42

I will save you some trouble then. Here is my WIP pkgbuild:

http://kmkeen.com/tmp/PKGBUILD.slic3r

Please note that there is some cruft that could probably be removed. I don't think any of the old patches are required.

I'll also be reviewing all of GPereira's contributions to the AUR. I've glanced at a couple, and so far they all had glaringly obvious red flags.

nickoe commented on 2019-06-30 18:41

@keenerd, because GPereira made a hostile takeover of this package and I have not reviewed them. But yeah, it looks like we are better of reverting all his changes.

EDIT: And it seems to be a bit hard to build 1.3.0 on arch.