Package Details: slic3r-prusa3d 1.37.2-1

Git Clone URL: https://aur.archlinux.org/slic3r-prusa3d.git (read-only)
Package Base: slic3r-prusa3d
Description: Updated Slic3r by Prusa3D with many bugfixes and new features
Upstream URL: http://www.prusa3d.com/
Licenses: AGPL3
Submitter: CReimer
Maintainer: CReimer
Last Packager: CReimer
Votes: 23
Popularity: 2.470605
First Submitted: 2016-10-30 19:16
Last Updated: 2017-10-21 17:34

Dependencies (22)

Required by (1)

Sources (3)

Latest Comments

nesteffe commented on 2017-10-27 03:41

If you are getting the "Could not find AlienWx" error I fixed it by rebuilding perl-alien-wxwidgets before building Slic3r.

kingcreole commented on 2017-10-20 07:31

hey, is this the same error that i'm getting?
Could NOT find AlienWx (missing: AlienWx_INCLUDE_DIRS AlienWx_LIBRARIES)

paneves commented on 2017-10-03 00:05

It works for me. Thanks a lot for your work and help.

CReimer commented on 2017-10-02 18:25

It took me some time to figure out what I did wrong. But it should work now.
Thanks for reporting.

CountMurphy commented on 2017-09-29 14:48

also getting the Slic3r/XS.pm error

fernando_morais commented on 2017-09-28 13:13

I'm in the same situation as @paneves, while building 1.37.1-1.

I'm stuck in the same error cited by him, even doing the recommended by @ArchMagic.

paneves commented on 2017-09-28 07:15

I was getting the same error as @ibbonkers. After installing perl-local-lib, installing slic3r-prusa3d still fails, now with error:
Can't locate Slic3r/XS.pm in @INC (you may need to install the Slic3r::XS module)

ibbonkers commented on 2017-09-27 18:52

error building 1.37.1-1...

Can't locate local/lib.pm in @INC (you may need to install the local::lib module) (@INC contains: /home/user/.cache/pacaur/slic3r-prusa3d/src/Slic3r/t/../lib /usr/lib/perl5/5.26/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.26/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.26/core_perl /usr/share/perl5/core_perl) at t/threads.t line 8.

had to install perl-local-lib. may want to add this as a dependency.

ArchMagic commented on 2017-09-08 23:56

If it's not building or you can't run it anymore, you need to go through and rebuild each of the perl modules listed in the dependencies. Or, just uninstall them and clear your pacman cache and rebuild this package. You don't need to download some scripts to do this for you.

agaskins commented on 2017-07-18 07:59

UPDATE: Fixed problem with the scripts provided here:
https://lists.archlinux.org/pipermail/arch-dev-public/2016-May/028034.html

After running the script run: pacman --noconfirm /path/to/generated/pacman.txt
(--noconfirm is optional, but for me it was quite a few packages to recompile, so it made life easier).

ORIGINAL COMMENT:
I'm getting: Wx.c: loadable library and perl binaries are mismatched (got handshake key 0xdb80080, needed 0xde00080)

Any ideas what I may have done to break this? I don't believe I've done anything except for system updates since it was working last.

All comments