Package Details: slic3r-git a-20

Git Clone URL: https://aur.archlinux.org/slic3r-git.git (read-only, click to copy)
Package Base: slic3r-git
Description: Slic3r is an STL-to-GCODE translator for RepRap 3D printers, aiming to be a modern and fast alternative to Skeinforge.
Upstream URL: http://slic3r.org/
Licenses: GPL
Conflicts: slic3r, slic3r-xs, slic3r-xs-git
Provides: slic3r, slic3r-xs, slic3r-xs-git
Submitter: swiftgeek
Maintainer: swiftgeek (nickoe)
Last Packager: swiftgeek
Votes: 21
Popularity: 0.005806
First Submitted: 2012-06-23 10:45
Last Updated: 2019-09-13 15:28

Dependencies (27)

Required by (2)

Sources (3)

Pinned Comments

swiftgeek commented on 2016-04-19 00:37

If something breaks on PKGBUILD side, please bother me directly on freenode (usually available at #slic3r) XS compilation requires more than 512MiB of installed RAM, adding same amount of swap makes it build (tested on armv7h, Allwinner A13)

Perl update guide: https://lists.archlinux.org/pipermail/arch-dev-public/2015-June/027236.html

or since 5.26:

pacman -Qqo '/usr/lib/perl5/5.26' where 5.26 is OLD version of perl

Latest Comments

1 2 3 4 5 6 ... Next › Last »

nickoe commented on 2021-01-24 14:29

@bartus, that error seems like something that should rather be fixed upstream.

bartus commented on 2021-01-24 14:15

Some crazy PKGBUILD you've got here (ღ˘⌣˘ღ)

If i might complain about something, countdown() function and whole interactive configuration is somewhat overkill, could we just use environment variables to control build process, check out blender-develop-git

Also there's an error when building with latest {gcc:10.1.0,boost:1.75}:

In file included from /usr/include/boost/mpl/aux_/include_preprocessed.hpp:37,
                 from /usr/include/boost/mpl/placeholders.hpp:43,
                 from /usr/include/boost/iterator/iterator_categories.hpp:16,
                 from /usr/include/boost/iterator/advance.hpp:11,
                 from /usr/include/boost/next_prior.hpp:25,
                 from /usr/include/boost/thread/futures/wait_for_any.hpp:20,
                 from /usr/include/boost/thread/future.hpp:41,
                 from /usr/include/boost/thread.hpp:24,
                 from src/libslic3r/libslic3r.h:17,
                 from src/libslic3r/SLAPrint.hpp:4,
                 from src/libslic3r/SLAPrint.cpp:1:
/usr/include/boost/mpl/aux_/preprocessed/gcc/placeholders.hpp:29:16: note:   ‘mpl_::_1’
   29 | typedef arg<1> _1;
      |                ^~
At global scope:
cc1plus: note: unrecognized command-line option ‘-Wno-undefined-var-template’ may have been intended to silence earlier diagnostics
error building src/libslic3r/SLAPrint.o from 'src/libslic3r/SLAPrint.cpp' at /usr/share/perl5/core_perl/ExtUtils/CBuilder/Base.pm line 185.

Perhaps includeing -Wno-undefined-var-template in CXXFLAGS could fix this.

Lucki commented on 2019-09-12 11:56

The source is available at

source=('git+https://github.com/slic3r/Slic3r.git' 'slic3r.desktop' 'slic3r.pl')

instead of

source=('git+https://github.com/alexrj/Slic3r.git' 'slic3r.desktop' 'slic3r.pl')

CReimer commented on 2017-03-24 12:38

We seem to have a different understanding on what VCS packages should look like. And the VCS package guidelines only state compatibility with 'latest trunk'. There's no word on being backwards compatible.

To find a regression it's way easier to just build Slic3r manually and use 'git bisect' to find the problem causing commit.

swiftgeek commented on 2017-03-24 01:57

@CReimer: Time was wasted on writing all of this for a reason - this is not for building present HEAD but also for tracking any regressions in slic3r

Though soon™ everything is going to move out of perl making everything simpler (conditionally again due to tracking regressions)

CReimer commented on 2017-03-24 00:29

This PKGBUILD seems unnecessary complex. Would you accept a patch to make thing more simple like it is in the slic3r-prusa3d-git package?

swiftgeek commented on 2017-02-28 02:17

Compatibility with pacaur has been improvemed + default branch was changed to master for now

swiftgeek commented on 2016-12-19 16:49

path of installed icons could be perhaps changed by fixing Slic3r:var (Slic3r.pm)
our $var = sub { decode_path($FindBin::Bin) . "/var/" . $_[0] };

swiftgeek commented on 2016-08-29 05:48

@Hibou First rule of cpan && archlinux
DO NOT USE CPAN
---
So you pretty much destroyed your system or trashed $HOME with cpan (depending on which user have you used)
Perl update guide: https://lists.archlinux.org/pipermail/arch-dev-public/2015-June/027236.html

Hibou commented on 2016-08-29 03:46

Tried reinstalling this program, so far when I try to run with the GUI I receive the following:

09:42:53 PM: Warning: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1009,wx containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1010,wx containers,compatible with 2.8).
Can't locate OpenGL.pm in @INC (you may need to install the OpenGL module) (@INC contains: /usr/bin/vendor_perl/lib /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl .) at /usr/share/perl5/vendor_perl/Slic3r/GUI/Plater/2DToolpaths.pm line 120.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/Slic3r/GUI/Plater/2DToolpaths.pm line 120.
Compilation failed in require at /usr/share/perl5/vendor_perl/Slic3r/GUI.pm line 16.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/Slic3r/GUI.pm line 16.
Compilation failed in require at (eval 64) line 1

I tried installing wx via the package wx-perl and also through cpan using 'cpan -i Wx', but the error persists! I can't get the command line to work (won't take my ini files or verbose inputs), so I was going to try using the GUI.