Package Details: sky 2.1.7434.1-1

Git Clone URL: https://aur.archlinux.org/sky.git (read-only)
Package Base: sky
Description: Lync and Skype for Business client on Linux
Upstream URL: https://tel.red
Licenses: custom: Copyright © 2015-2018 TEL.RED LLC
Submitter: telred
Maintainer: telred
Last Packager: telred
Votes: 59
Popularity: 0.034635
First Submitted: 2015-05-13 14:01
Last Updated: 2019-06-05 12:07

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 ... Next › Last »

telred commented on 2016-11-02 14:22

It could be an openssl version problem, but not sure.
We will fix that issue in our repo.

jlaunay commented on 2016-11-02 14:17

@telred, thanks for the suggestion, no problem with your AppImage, I can connect.
I have no idea which dependency could cause this problem on my box, any idea ?

telred commented on 2016-11-02 13:53

Jérôme,you can try our AppImage package at tel.red/linux.php

jlaunay commented on 2016-11-02 12:34

I have 2 arch boxes, on the first one, using gnome3 sky works perfectly, on the second one using i3 I can't connect and get the log below :

2016-11-02 13:29:50.820 msw_reg.c thr0x7f55e97ERROR: app version, code: 6343(core:5909, lib:109, app:325), name: 2.1.6343, os_id: Others_64
2016-11-02 13:30:05.299 msw_reg.c thr0x7f55e97ERROR: username: xxxxxxx, sipDomain: xxxxxxx.fr, ntmlDomain: xxxxxxx, ntlmUser: xxxxxxx
2016-11-02 13:30:05.300 msw_reg.c thr0x7f55e97ERROR: after calculating, ntmlDomain: xxxxxxx, ntlmUser: xxxxxxx
2016-11-02 13:30:05.300 msw_reg.c thr0x7f55e97ERROR: audio capture dev: -1, audio playback dev: -2
2016-11-02 13:30:05.300 msw_reg.c thr0x7f55e97ERROR: video capture dev: -1, video rener dev: -2
2016-11-02 13:30:05.805 sip_auth_tls_d wync_ua[0]ERROR: !...did parse mexurl successfully
2016-11-02 13:30:06.791 pjsua_acc.c wync_ua[0]ERROR: ....SIP registration error: Unknown pjsip error 171115 [status=171115]

No problem with credentials (same one the first box), does someone have an idea and/or have already seen this "unknow error 171115" ?

jpalko commented on 2016-10-07 05:54

Started complaining this to me after updating my system this morning:
/usr/lib/sky/sky: /usr/lib/sky/lib/libcurl.so.4: no version information available (required by /usr/lib/sky/lib/libsipw.so.1)
/usr/lib/sky/sky: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /usr/lib/sky/lib/libfreerdp-shadow.so.2.0)
/usr/lib/sky/sky: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /usr/lib/sky/lib/libfreerdp.so.2.0)
/usr/lib/sky/sky: /usr/lib/libssl.so.1.0.0: no version information available (required by /usr/lib/sky/lib/libfreerdp.so.2.0)
/usr/lib/sky/sky: /usr/lib/libssl.so.1.0.0: no version information available (required by /usr/lib/sky/lib/libwinpr.so.1.1)
/usr/lib/sky/sky: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /usr/lib/sky/lib/libwinpr.so.1.1)

No additional output after those... also executing with strace it does not show anything additional after those.

Tried quickly the sky.sh idea but substituted /usr/lib/sky/lib in LD_LIBRARY_PATH.

peshane commented on 2016-08-09 15:35

Hi,

When connecting, sky just segfault few seconds/minutes later with a 139 exit code.

Debug show this:
2016-08-09 17:15:55.907 sip_transport. wync_ua[0]DEBUG: !pjsip_transport_destroy
2016-08-09 17:15:55.907 activesock.c wync_ua[0] INFO: prepare pj_ioqueue_unregister asock->key which has fd: 29
2016-08-09 17:15:55.907 ioqueue_common wync_ua[0] INFO: uuuuuuuu unregister key: 20494504 prepare close key->fd: 29, after decrease current ioqueue->count: 1
2016-08-09 17:15:55.907 ioqueue_common wync_ua[0] INFO: after close key->fd, clear callback
2016-08-09 17:15:55.907 tlsc0x16de240 wync_ua[0]DEBUG: TLS transport destroyed normally
/usr/bin/sky : ligne 20 : 24837 Segmentation fault (core dumped) ${_SKY_PREFIX}/sky "$@"

Not sure to have something usefull in ~/.sky2/logs/native too (file wcorestack.log is ~1 minute older than the core dump)

I try to force LD_LIBRARY_PATH without success. A support ticket have been open but well, I still wait.

Just digging a little with a coredump, maybe be qt related, don't know:
#0 0x00007fa5be4d6364 in free () from /usr/lib/libc.so.6
#1 0x00007fa5bfe396dd in QImageData::~QImageData() () from /usr/lib/libQt5Gui.so.5
#2 0x00007fa5bfe39f57 in QImage::~QImage() () from /usr/lib/libQt5Gui.so.5
#3 0x00007fa5bfe7669c in QRasterPlatformPixmap::~QRasterPlatformPixmap() () from /usr/lib/libQt5Gui.so.5
#4 0x00007fa5bfe766b9 in QRasterPlatformPixmap::~QRasterPlatformPixmap() () from /usr/lib/libQt5Gui.so.5
#5 0x00007fa5bfe67fa1 in QPixmap::~QPixmap() () from /usr/lib/libQt5Gui.so.5
#6 0x00007fa5bfe6d52f in ?? () from /usr/lib/libQt5Gui.so.5
#7 0x00007fa5bfe6dbd5 in ?? () from /usr/lib/libQt5Gui.so.5
#8 0x00007fa5bf56b303 in QObject::event(QEvent*) () from /usr/lib/libQt5Core.so.5
#9 0x00007fa5c0587e3c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#10 0x00007fa5c058f5b1 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#11 0x00007fa5bf53ec80 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/libQt5Core.so.5
#12 0x00007fa5bf59251e in QTimerInfoList::activateTimers() () from /usr/lib/libQt5Core.so.5
#13 0x00007fa5bf592a79 in ?? () from /usr/lib/libQt5Core.so.5
#14 0x00007fa5b1f0add7 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#15 0x00007fa5b1f0b040 in ?? () from /usr/lib/libglib-2.0.so.0
#16 0x00007fa5b1f0b0ec in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#17 0x00007fa5bf59357f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#18 0x00007fa5bf53d0da in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#19 0x00007fa5bf5455cc in QCoreApplication::exec() () from /usr/lib/libQt5Core.so.5
#20 0x0000000000425129 in main ()

frebib commented on 2016-08-03 08:11

Attempting to install this via pacaur yields 'no results found for qt5-base<=5.7' but installing manually by installing libcurl-compat and libjpeg6-turbo first then running the PKGBUILD works just fine.

telred commented on 2016-05-31 18:29

We are close to releasing a fix for this and many other build issues.
Sorry for the delay.

belette commented on 2016-05-31 18:23

Hi,
Same issue as aswieton
any update for the next release update?
many thanks
belette

telred commented on 2016-05-18 12:33

Hi aswieton,

Sorry, please wait for our next Arch build. We are fixing this now.
I hope to release next week.