Package Details: sipp 3.5.2-1

Git Clone URL: https://aur.archlinux.org/sipp.git (read-only)
Package Base: sipp
Description: A free Open Source test tool / traffic generator for the SIP protocol.
Upstream URL: http://sipp.sourceforge.net/
Licenses: GPL
Submitter: None
Maintainer: ilmagno
Last Packager: xdevla
Votes: 19
Popularity: 0.000014
First Submitted: 2009-10-12 11:04
Last Updated: 2018-08-30 05:09

Latest Comments

1 2 Next › Last »

deep_thought commented on 2019-07-09 12:11

this does not compile with gcc (version 9), but it does with gcc8:

diff --git a/PKGBUILD b/PKGBUILD
index 215e4ae..f31aefa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,6 +9,7 @@ arch=('i686' 'x86_64')
 url="http://sipp.sourceforge.net/"
 license=('GPL')
 depends=('openssl' 'libpcap' 'lksctp-tools')
+makedepends=('gcc8')
 source=(https://github.com/SIPp/${pkgname}/releases/download/v${pkgver}/sipp-${pkgver}.tar.gz)
 sha256sums=('875fc2dc2e46064aa8af576a26166b45e8a0ae22ec2ae0481baf197931c59609')

@@ -17,6 +18,8 @@ build() {
   sed -i 's/SSL_library_init/SSL_CTX_new/' configure.ac
   sed -i 's/CRYPTO_num_locks/CRYPTO_free/' configure.ac
   sed -i 's/TLSv1_method/TLS_method/' src/socket.cpp
+  CC=/usr/bin/gcc-8 \
+  CXX=/usr/bin/g++-8 \
   ./build.sh --with-pcap --with-sctp --with-openssl
 }

josemslopes commented on 2017-06-29 13:13

I have the same issue with openssl.

I solved changing the build section of PGKBUILD with:
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
sed -i 's/SSL_library_init/SSL_CTX_new/' configure.ac
sed -i 's/CRYPTO_num_locks/CRYPTO_free/' configure.ac
sed -i 's/TLSv1_method/TLS_method/' src/socket.cpp
./build.sh --with-pcap --with-sctp --with-openssl
}

This issue is caused because of openssl-1.1, i notice a workaround solution at https://github.com/SIPp/sipp/pull/304 .

notuxius commented on 2017-06-12 05:52

error upon build:

checking for SSL_library_init in -lssl... no
configure: error: ssl library missing
==> ERROR: A failure occurred in build().

xdevla commented on 2015-07-31 14:10

Changed, thanks for noticing

bidulock commented on 2015-07-31 03:06

Package 3.4.0-2 depends on "openssl", however, --with-openssl flag is not being passed when building.

papo483 commented on 2013-12-01 13:33

New version out: http://sourceforge.net/projects/sipp/files/sipp/3.4/sipp-3.3.990.tar.gz

xdevla commented on 2013-03-29 07:12

Thanks, updated

senorsmile commented on 2013-03-28 17:56

New version out: http://sourceforge.net/projects/sipp/files/sipp/3.3/sipp-3.3.tar.gz/download

xdevla commented on 2010-06-01 07:17

Absolutely sure, even the md5sum is incorrect...

Anonymous comment on 2010-05-26 18:31

Are you realy sure, that it is necessary to put limits.h there? I havn't problem with it..