Package Details: singularityviewer 1.8.7.6866-3

Git Clone URL: https://aur.archlinux.org/singularityviewer.git (read-only)
Package Base: singularityviewer
Description: A Second Life (secondlife) protocol compatible client application, used to access its service as well as a number of other such as those based upon OpenSim platform
Upstream URL: http://www.singularityviewer.org/
Keywords: games Life Open opensim Second secondlife Simulator
Licenses: custom
Submitter: GordonGR
Maintainer: GordonGR
Last Packager: GordonGR
Votes: 13
Popularity: 0.000000
First Submitted: 2012-04-01 16:05
Last Updated: 2017-02-27 19:21

Dependencies (21)

Sources (5)

Latest Comments

1 2 3 4 Next › Last »

sudoquai commented on 2019-07-19 20:41

ping @GordonGR - This package still doesn't work. Please check my comments below.

I am going to flag this package as outdated again. Please fix the issue in the PKGBUILD instead of reverting my flag.


==> Making package: singularityviewer 1.8.7.6866-3 (Fri Jul 19 22:37:57 2019) ==> Retrieving sources... -> Downloading Singularity_1_8_7_6866_x86_64.tar.xz... % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 0 0 0 0 0 0 0 0 --:--:-- 0:02:09 --:--:-- 0 curl: (7) Failed to connect to 67.170.30.149 port 80: Connection timed out ==> ERROR: Failure while downloading http://67.170.30.149/Singularity_1_8_7_6866_x86_64.tar.xz Aborting... Error downloading sources: singularityviewer

sudoquai commented on 2019-07-16 15:15

Something is wrong here with the PKGBUILD:

Tries to download from: source=("http://67.170.30.149/Singularity_${pkgver}$CARCH.tar.xz"

But it should be: source=("https://virtual-nexus.xyz/down/Singularity_${pkgver}$CARCH.tar.xz"

http://www.singularityviewer.org/ is referring to https://virtual-nexus.xyz so it should be correct.

Please correct this if possible, i've flagged it as outdated for the time.

Thx.

sudoquai commented on 2019-07-16 15:14

Something is wrong here with the PKGBUILD:

Tries to download from: source=("http://67.170.30.149/Singularity_${pkgver}$CARCH.tar.xz"

But it should be: source=("https://virtual-nexus.xyz/down/Singularity_${pkgver}$CARCH.tar.xz"

Please correct this if possible, i've flagged it as outdated for the time.

Thx.

GordonGR commented on 2018-08-20 12:13

Yes, I know. For some reason the stable build isn't available (!) See the comment right below yours. Use the alpha version.

Mind you, if upstream is as dead as it seems to be, I will request the package deleted by the end of the year. I moved to firestorm about a year ago myself. If you want a good and maintainted v1-type viewer, I suggest Cool VL Viewer (I maintain it as well).

skome commented on 2018-08-20 00:28

THANKS. But it seems to need some attention:

PKGBUILD says, source=("http://67.170.30.149/Singularity_${pkgver}$CARCH.tar.xz"

and makepkg -si says, Failed to connect to 67.170.30.149 port 80: Connection refused

Just in case I also tried https but no luck.

GordonGR commented on 2017-06-19 13:12

Fennectech: At http://www.singularityviewer.org/downloads under the Linux64 section, it says “Singularity Viewer 1.8.7(6866) 64-bit Linux (missing, see alphas)”. I haven't the faintest idea why this is so… but anyway, you can use the alpha package https://aur.archlinux.org/packages/singularityviewer-alpha/ .

fennectech commented on 2017-06-19 08:08

Downloading doesnt work on the latest version Would also like to see an alpha version

GordonGR commented on 2017-02-27 19:22

I will let upstream know, but I wouldn't expect much. Their building system isn't cutting edge, so they may not have the newest harfbuzz.

For the time being, I added the binaries from an old version of harfbuzz and CEF works properly.

Thanks for noticing and debugging, Test0.

test0 commented on 2017-02-24 06:56

Apart from an issue with harfbuzz[1], everything seems to be fine.

[1]: The cef plugin fails with this error message: "undefined reference to `FT_Get_Var_Blend_Coordinates'". It's probably due to the relatively recent ABI change, in which case upstream will need to rebuild against the new harfbuzz. Downgrading harfbuzz fixes this.

GordonGR commented on 2017-01-12 18:31

It took me ages, but I did what you asked. I also reworked the dependencies in general, according to namcap's result. Tell me if it's all right please.