Package Details: signal-desktop-bin 1.27.4-1

Git Clone URL: https://aur.archlinux.org/signal-desktop-bin.git (read-only)
Package Base: signal-desktop-bin
Description: Private messaging from your desktop
Upstream URL: https://github.com/signalapp/Signal-Desktop
Keywords: messenger secure
Licenses: GPL3
Conflicts: signal
Provides: signal-desktop
Submitter: jbbr
Maintainer: jbbr (buzo)
Last Packager: jbbr
Votes: 166
Popularity: 4.392456
First Submitted: 2017-10-31 20:04
Last Updated: 2019-10-10 19:58

Pinned Comments

tinxy commented on 2019-05-31 15:47

Signal Desktop does not work if your /tmp is mounted with option noexec -- see https://github.com/signalapp/Signal-Desktop/issues/2707

As a workaround one can use an alternative dir like so:

mkdir -p "$HOME"/tmp/signal

export TMPDIR="$HOME"/tmp/signal

signal-desktop

buzo commented on 2018-10-30 10:50

Apparently upstream removes the old package immediately when releasing a new version. So if you encounter a 404 error when building, just click on “Flag package out-of-date” above. Thanks!

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

je-vv commented on 2019-02-03 01:52

Can a new "signal-desktop-tray.desktop" file be provided by the package that calls the executable as follows:

Exec=signal-desktop --start-in-tray %U

And perhaps changing the "signal-desktop.desktop" so that it calls the executable as:

Exec=signal-desktop %U

Using the wrapper under /usr/bin, rather than calling directly the /opt/Signal binary.

Thanks !

buzo commented on 2019-01-26 20:13

gesh: I don't know anything about 92c2a0f and I cannot reproduce this issue, nor do I understand the connection to the sqlite PKGBUILD.

jbbr commented on 2019-01-25 10:27

@internetuser Is there any more output or just the segmentation fault? I can't reproduce this on my system.

internetuser commented on 2019-01-25 03:51

I got $signal-desktop Segmentation fault (core dumped) Am I missing something here?

gesh commented on 2019-01-24 03:55

Apparently 92c2a0f added a dep on sqlite being compiled with fts5. However, judging by sqlite's PKGBUILD, this shouldn't be an issue. Tracked upstream at https://github.com/signalapp/Signal-Desktop/issues/3080

mr.buffed commented on 2018-12-19 13:40

@ogasser: Thanks for the heads-up, I'll check the issue over there and provide some debug info!

ogasser commented on 2018-12-17 13:37

@mr.buffed: There is at least one open issue on Github [1] for Signal desktop being extremely slow and laggy. Maybe you can provide debug info there.

[1] https://github.com/signalapp/Signal-Desktop/issues/2613

mr.buffed commented on 2018-12-15 17:14

Installation and starting works well. However, the UI gets terribly slow and laggy after some seconds. Has anyone the same error or found a solution to that? Couldn't find anything related somewhere else.

buzo commented on 2018-10-30 10:50

Apparently upstream removes the old package immediately when releasing a new version. So if you encounter a 404 error when building, just click on “Flag package out-of-date” above. Thanks!

a0a0 commented on 2018-10-30 03:28

now only version 1.17.2 is available.. of course you need to change the sha256sum in PKGBUILD as well