Package Details: shrew-vpn-client 2.2.1-5

Git Clone URL: https://aur.archlinux.org/shrew-vpn-client.git (read-only, click to copy)
Package Base: shrew-vpn-client
Description: A portable VPN client for Linux - Qt GUI only
Upstream URL: http://www.shrew.net/
Licenses: osi
Conflicts: shrew-vpn-client-alpha
Submitter: chrishamm
Maintainer: figue (figuepluto, jfigueras)
Last Packager: figuepluto
Votes: 42
Popularity: 0.000021
First Submitted: 2009-07-19 02:36
Last Updated: 2019-02-15 20:14

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

ManU commented on 2012-04-23 19:05

Basic-Master,
it only compiles when you add QTDIR=/opt/qt before running cmake, since the default path is /usr where only qt4 is installed, pacman Ql qt3 shows that it is installed under /opt/qt so atm broken package.

ManU commented on 2012-04-23 18:56

Basic-Master,
it only compiles when you add QT3_DIR=/opt before running cmake, since the default path is /usr where only qt4 is installed, so atm broken package.

Maxr commented on 2012-01-04 22:23

Hey, shrew will log to /var/log/iked.log. You could add a logrotate config to /etc/logrotate.d/ to prevent iked.log from growing and growing and...

Something like this maybe?

/etc/logrotate.d/iked.conf:

/var/log/iked.log {
notifempty
missingok
copytruncate
rotate 1
compress
weekly
}

chrishamm commented on 2010-11-18 21:49

ferda: I just noticed this VPN client requires Qt3, so either get the updated version or install qt3 by hand ;)

chrishamm commented on 2010-11-14 20:19

I'm sorry I haven't updated this package yet but my KDE setup was kind of messed up. This updated package will compile properly again and install the man pages into the right directories (thanks to das-ich). If you have any other concerns, feel free to post them here.

ferda commented on 2010-10-19 00:58

2.1.7 is out.
This package doesn't compile for me, it stops right in the beginning when performing the tests:
CMake Error at CMakeLists.txt:423 (message):
Unable to locate required package : QT
cmake 2.8.2-3
qt 4.7.0-4

ferda commented on 2010-10-19 00:57

2.1.7 is out.
This package doesn't compile for me, it stops right in the beginning when performing the tests:
CMake Error at CMakeLists.txt:423 (message):
Unable to locate required package : QT
cmake 2.8.2-3
qt 4.7.0-4

das-ich commented on 2010-09-14 18:15

please add -DPATH_MAN=/usr/share, otherwise mans installed to /usr/local

chrishamm commented on 2010-08-21 10:43

Alright, both packages are now up in AUR. In case you want to keep using the alpha version, search and install the 'shrew-vpn-client-alpha' package.

I'm glad I don't need that libcrypto work-around for the latest stable version any more. I hope you enjoy this new version. Unlike in the alpha version, you can start the GUI using the 'ikea' command. Just make sure you've started the iked daemon before you try to connect to other networks.

chrishamm commented on 2010-08-21 10:18

Heh yeah, actually I took the alpha version because the prior stable version didn't even compile for me (got some ugly compile errors there). When I tested it, I didn't notice any problems though.

I just saw they released a new stable version which compiles flawlessly again. That means I'll replace this packet ASAP and move the current alpha packet to another package.