Package Details: shopify-themekit-bin-noconflict 1.1.4-1

Git Clone URL: https://aur.archlinux.org/shopify-themekit-bin-noconflict.git (read-only, click to copy)
Package Base: shopify-themekit-bin-noconflict
Description: A cross-platform tool for building Shopify Themes - renamed binary to theme-shopify
Upstream URL: https://github.com/Shopify/themekit
Licenses: MIT
Conflicts: shopify-themekit
Provides: shopify-themekit
Submitter: aviallon
Maintainer: aviallon
Last Packager: aviallon
Votes: 2
Popularity: 0.088476
First Submitted: 2020-04-10 08:47
Last Updated: 2021-01-11 15:06

Dependencies (0)

Required by (0)

Sources (1)

Latest Comments

aviallon commented on 2021-01-11 15:04

@gavsiu no, it is not possible, unless you run this as root, but I highly recommend you to avoid doing that.

EDIT: just updated it. If I'm too slow updating it, you can update it for yourself by editing the PKGBUILD and building it without an AUR helper.

gavsiu commented on 2021-01-02 18:47

Is there a way to allow this to update by running theme-shopify update like how it was originally supposed to using theme update?

theme-shopify update
An update for Themekit is available. To update please run `theme update`
Updating from 1.1.2 to latest
Could not update and had to roll back. open /usr/bin/.theme-shopify.new: permission denied

aviallon commented on 2020-10-15 13:29

@FabioLolix the original package conflicts with https://www.archlinux.org/packages/extra/x86_64/discount/ on file /usr/bin/theme. Since I needed both, I had to rename the binary.

FabioLolix commented on 2020-09-06 14:41

What is the point of this pkgbuild?