Package Details: setzer-git r314.9faed5-1

Git Clone URL: https://aur.archlinux.org/setzer-git.git (read-only, click to copy)
Package Base: setzer-git
Description: LaTeX editor written in Python with Gtk
Upstream URL: https://github.com/cvfosammmm/Setzer
Licenses: GPL3
Submitter: FalkAlexander
Maintainer: FalkAlexander
Last Packager: FalkAlexander
Votes: 1
Popularity: 0.000903
First Submitted: 2019-10-24 17:16
Last Updated: 2020-06-24 16:24

Latest Comments

jenz commented on 2020-10-30 13:21

I get this error when running setzer, I take this' out of date then?:

Traceback (most recent call last):
  File "/usr/bin/setzer", line 28, in <module>
    from setzer.workspace.workspace import Workspace
  File "/usr/lib/python3.8/site-packages/setzer/workspace/workspace.py", line 22, in <module>
    from setzer.document.document import Document, LaTeXDocument, BibTeXDocument
  File "/usr/lib/python3.8/site-packages/setzer/document/document.py", line 21, in <module>
    import setzer.document.document_controller as document_controller
  File "/usr/lib/python3.8/site-packages/setzer/document/document_controller.py", line 28, in <module>
    from setzer.dialogs.dialog_locator import DialogLocator
  File "/usr/lib/python3.8/site-packages/setzer/dialogs/dialog_locator.py", line 18, in <module>
    import setzer.dialogs.about.about as about_dialog
  File "/usr/lib/python3.8/site-packages/setzer/dialogs/about/about.py", line 24, in <module>
    from setzer.app.service_locator import ServiceLocator
  File "/usr/lib/python3.8/site-packages/setzer/app/service_locator.py", line 19, in <module>
    gi.require_version('GtkSource', '4')
  File "/usr/lib/python3.8/site-packages/gi/__init__.py", line 129, in require_version
    raise ValueError('Namespace %s not available for version %s' %
ValueError: Namespace GtkSource not available for version 4