Package Details: session-desktop 1.0.6-1

Git Clone URL: https://aur.archlinux.org/session-desktop.git (read-only, click to copy)
Package Base: session-desktop
Description: Private messaging from your desktop
Upstream URL: https://getsession.org
Keywords: loki messenger session signal
Licenses: GPL-3.0
Conflicts: session-desktop-appimage, session-desktop-bin, session-desktop-git
Provides: session-messenger-desktop
Submitter: xXR01I1Xx
Maintainer: xXR01I1Xx
Last Packager: xXR01I1Xx
Votes: 3
Popularity: 0.178756
First Submitted: 2020-03-23 07:39
Last Updated: 2020-04-03 10:20

Latest Comments

linuxninja commented on 2020-05-25 00:53

Looks like the build requirements should include both python and python2. I've updated the .patch and emailed it.

This now builds on a cleanly installed Arch Linux build machine.

linuxninja commented on 2020-05-24 00:47

I've emailed you a .patch for updating to 1.0.8 and a good bit of cleanup and re-work.

https://pastebin.com/d7zZkeAJ

xXR01I1Xx commented on 2020-03-25 07:40

@chilledfrogs I've updated the PKGBUILD, maybe it'll work now.

chilledfrogs commented on 2020-03-24 22:36

@xXR01I1Xx Didn't change anything...

xXR01I1Xx commented on 2020-03-24 18:53

@AkariMarisa try to cleanbuild the package. If this doesn't help reinstall yarn and nvm.

AkariMarisa commented on 2020-03-24 18:40

When I update package, yarn reported a error, that failed the build. Here is the error:

==> Starting build()...
Now using node v10.13.0 (npm v6.4.1)
yarn install v1.22.4
[1/6] Validating package.json...
[2/6] Resolving packages...
[3/6] Fetching packages...
error An unexpected error occurred: "Unexpected end of data".
info If you think this is a bug, please open a bug report with the information provided in "/home/akari/.cache/pikaur/build/session-desktop/src/session-desktop/yarn-error.log".
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
==> ERROR: A failure occurred in build().
    Aborting...

And here is the yarn error log:

Arguments: 
  /home/akari/.nvm/versions/node/v10.13.0/bin/node /usr/bin/yarn install --frozen-lockfile

PATH: 
  /home/akari/.nvm/versions/node/v10.13.0/bin:/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl:/home/akari/.emacs.d/bin:/home/akari/.emacs.d/bin

Yarn version: 
  1.22.4

Node version: 
  10.13.0

Platform: 
  linux x64

Trace: 
  Error: Unexpected end of data
      at Extract.module.exports.Extract._final (/usr/lib/node_modules/yarn/lib/cli.js:150889:42)
      at callFinal (/usr/lib/node_modules/yarn/lib/cli.js:74039:10)
      at process._tickCallback (internal/process/next_tick.js:63:19)

xXR01I1Xx commented on 2020-03-24 15:48

@chilledfrogs try to write this in your .bashrc: export NVM_DIR="/home/<username>/.nvm" If your home directory is a symlink to another drive, use the direct path to this drive instead.

chilledfrogs commented on 2020-03-24 14:55

I hope this isn't something specific to my setup, but when trying to upgrade, whether I cleanBuild or not, I get the following error:

==> Starting build()...
nvm is not compatible with the npm config "prefix" option: currently set to "/usr"
Run `npm config delete prefix` or `nvm use --delete-prefix v10.13.0 --silent` to unset it.
nvm is not compatible with the npm config "prefix" option: currently set to "/usr"
Run `npm config delete prefix` or `nvm use --delete-prefix v10.13.0` to unset it.
==> ERROR: A failure occurred in build().
    Aborting...
Error making: session-desktop

Any ideas?