Package Details: servo-git r44260.bd92fad81a-1

Git Clone URL: https://aur.archlinux.org/servo-git.git (read-only, click to copy)
Package Base: servo-git
Description: Parallel Browser Project: web browser written in Rust
Upstream URL: https://github.com/servo/servo
Keywords: browser engine rust
Licenses: MPL
Conflicts: servo
Provides: servo
Submitter: beatgammit
Maintainer: alerque (farseerfc, yar, hcsch)
Last Packager: alerque
Votes: 43
Popularity: 0.000052
First Submitted: 2013-08-16 05:23
Last Updated: 2021-08-05 20:46

Dependencies (26)

Required by (0)

Sources (1)

Latest Comments

1 2 3 4 5 6 Next › Last »

alerque commented on 2021-09-21 17:10

@mble It looks like the Arch [community] package for python-blessings is newer than this build demands. Probably the thing to do is patch the servo sources to be more accepting of other versions, then if it doesn't build with 1.7.x submit a patch to servo upstream to fix it. I'm happy to accept such a patch (either in comments with git format-patch or as a PR on this repository) but I'm unlikely to have time to hack around on this build any time too soon. Also either way this should be reported upstream.

mble commented on 2021-09-21 16:42

Updating files:  98% (99189/101213)
Updating files:  99% (100201/101213)
Updating files: 100% (101213/101213)
Updating files: 100% (101213/101213), done.
==> Starting prepare()...
==> Starting pkgver()...
==> Removing existing $pkgdir/ directory...
==> Starting build()...
Obtaining file:///var/tmp/pamac-build-mble/servo-git/src/servo-git/python/tidy (from -r /var/tmp/pamac-build-mble/servo-git/src/servo-git/python/requirements.txt (line 35))
Collecting blessings==1.6
  Using cached blessings-1.6.tar.gz (19 kB)
    ERROR: Command errored out with exit status 1:
     command: /var/tmp/pamac-build-mble/servo-git/src/servo-git/python/_virtualenv3.9/bin/python -c 'import io, os, sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-dwdd9aw3/blessings_044041f758424b8c8c5d7f6d82c2deeb/setup.py'"'"'; __file__='"'"'/tmp/pip-install-dwdd9aw3/blessings_044041f758424b8c8c5d7f6d82c2deeb/setup.py'"'"';f = getattr(tokenize, '"'"'open'"'"', open)(__file__) if os.path.exists(__file__) else io.StringIO('"'"'from setuptools import setup; setup()'"'"');code = f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' egg_info --egg-base /tmp/pip-pip-egg-info-dmkmryeq
         cwd: /tmp/pip-install-dwdd9aw3/blessings_044041f758424b8c8c5d7f6d82c2deeb/
    Complete output (1 lines):
    error in blessings setup command: use_2to3 is invalid.
    ----------------------------------------
WARNING: Discarding https://files.pythonhosted.org/packages/af/4a/61acd1c6c29662d3fcbcaee5ba95c20b1d315c5a33534732b6d81e0dc8e8/blessings-1.6.tar.gz#sha256=edc5713061f10966048bf6b40d9a514b381e0ba849c64e034c4ef6c1847d3007 (from https://pypi.org/simple/blessings/). Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.
ERROR: Could not find a version that satisfies the requirement blessings==1.6 (from versions: 1.0, 1.1, 1.2, 1.3, 1.4, 1.5, 1.5.1, 1.6, 1.6.1, 1.7)
ERROR: No matching distribution found for blessings==1.6
"/var/tmp/pamac-build-mble/servo-git/src/servo-git/python/_virtualenv3.9/bin/python" "-m" "pip" "install" "-I" "-r" "/var/tmp/pamac-build-mble/servo-git/src/servo-git/python/requirements.txt" failed with error code 1:
Output:
Error:
==> ERROR: A failure occurred in build().
    Aborting...

yar commented on 2021-07-06 00:15

Same error as @hcsch. Please fix or orphan, thanks.

hcsch commented on 2021-03-21 12:10

I got "Python virtualenv is not installed. Please install it prior to running mach." as an error when trying to install this with yay (I also tried plain makepkg). It seems to me that mach uses python (3) instead of python2. Switching the makedeps python packages from python2 to python worked for me.

farseerfc commented on 2020-08-17 06:56

@dmitmel good point, I stopped installing libraries in PKGBUILD

dmitmel commented on 2020-08-12 13:41

Are the libraries in target/release/deps actually needed? The servo binary isn't dynamically linked with them, can work just fine without them, and they are mostly (if not all) procedural macro packages, so are executed at build-time and generate code, yet contribute 149 megabytes (on my machine at least) to the installed package.

Scimmia commented on 2020-05-19 16:36

lilac, see the note here: https://wiki.archlinux.org/index.php/Arch_User_Repository#Flagging_packages_out-of-date

Stop the insane bumping.

farseerfc commented on 2018-06-07 06:44

add to add clang to makedepends. It will look for libclang.so when build.

hcorion commented on 2018-05-04 16:41

This should require rustup as a makedepend.

jnbek commented on 2017-08-28 01:58

Passing this back to whomever can take care of it