Package Details: sentry 9.1.2-1

Git Clone URL: https://aur.archlinux.org/sentry.git (read-only, click to copy)
Package Base: sentry
Description: Python-based realtime logging and aggregation server.
Upstream URL: http://pypi.python.org/pypi/sentry
Licenses: BSD
Submitter: zancarius
Maintainer: zancarius
Last Packager: zancarius
Votes: 14
Popularity: 0.82
First Submitted: 2012-11-04 17:15
Last Updated: 2019-08-31 02:03

Pinned Comments

zancarius commented on 2020-01-23 21:38

I have spent some time exploring options for upgrading this PKGBUILD to the latest version of Sentry and have encountered blocking changes that do not appear to have a clear resolution.

Currently, there were two PKGBUILDs that provide our required Clickhouse dependency but neither of these build successfully. Near as I can tell, some of Clickhouse's upstream dependencies have known issues that as yet have no resolution outside attempting to patch either Clickhouse or wait for the upstream developers to address these deficiencies. This is not something either myself or the maintainer(s) of the Clickhouse PKGBUILD(s) can address (not easily, anyway).

Consequently, I will be updating this PKGBUILD, bumping the pkgrel in effort to increase the visibility of this issue. We will be holding Sentry at its current state until we have a clear path forward.

If you need Sentry 10.x.x in your environment, consider installing their official Docker packages. This is the currently recommended method for installing Sentry.

zancarius commented on 2020-01-17 06:45

Sentry v10.0.0 is out, but I will not be upgrading this package for some time. In fact, I'm not sure when an upgrade will be available because the number of additional service dependencies has since exploded.

To illustrate, Sentry v10.x now depends on:

  • Zookeeper
  • Kafka
  • Clickhouse
  • Snuba

I don't believe Snuba can be disabled in Sentry post-v9.1.2. If this is true, then this means that Sentry now has an implicit dependency on the JRE which may be prohibitive for those users who are running Sentry on lower end hardware or memory-constrained environments.

The official installation guide recommends installing the on-premise edition of Sentry via Docker and advises against source installation, which is what we're doing here.

This leaves us with a couple of options (plus a third thrown in as an either/or):

1) Upgrade anyway and add a host of other dependencies to the PKGBUILD that may surprise some users. Given that Sentry is a complex piece of software to install, this will only add to the complexity and will require additional packages, configuration, etc., that will need to be completed before Sentry can even be upgraded. (The migration process moves events from the database into Snuba, for example.)

2) Cheat and take the easy way out; deprecate this PKGBUILD and point users to the official Docker images. There's no point trying to wrap the Docker images in a PKGBUILD.

3) Rename this package to something like sentry9.1, freezing it at this version, and then pick options #1 or #2.

When I have some time this weekend, I may ask around for advice. There's no easy solution in this case, and I know from past experience with this package that there are some users who may be uninterested in running Sentry v10 if it requires configuring at least 3 other services. I will leave this package flagged for the time being in the hopes users of this package check here.

Latest Comments

« First ‹ Previous ... 4 5 6 7 8 9 10 Next › Last »

mitchhentges commented on 2016-03-15 15:02

I've submitted a PR to Sentry[0], you might not need my patch if it's in when you update this package.

[0] https://github.com/getsentry/sentry/pull/2846

mitchhentges commented on 2016-03-15 13:34

I've got a sick patch for fixing `systemctl stop sentry`:
http://hastebin.com/adoxupikiv.avrasm

See https://github.com/getsentry/sentry/issues/2845 for details

mitchhentges commented on 2016-03-15 11:50

Awesome package! Two small issues:
* `systemctl stop sentry` doesn't actually stop the service, and just hangs. Not sure if that's a sentry bug, or an issue with this AUR itself. Sorry for my lack of knowledge, I'm getting there ;)
* Sentry 8.2.3 is out! https://github.com/getsentry/sentry/releases/tag/8.2.3

zancarius commented on 2015-09-10 06:08

Addendum to my previous post: It would appear that the sentry.tasks.check_alerts error is only likely to appear if you've forgotten to regenerate your Sentry configuration (sentry init).

Thusfar, I'm not aware of any other causes.

zancarius commented on 2015-09-09 06:06

When upgrading to Sentry 7.7.0, you may notice celerybeat warnings containing the following:

> KeyError: 'sentry.tasks.check_alerts'

It appears this task has been removed in recent versions of Sentry and the error can be ignored [1][2].

[1] https://github.com/getsentry/sentry/issues/1665
[2] https://github.com/getsentry/sentry/issues/1584

If it's particularly noisome, ask upstream and send me a pull request (on the Github repo) if you run across a workaround/fix. Otherwise, wait until a later version resolves the warning.

zancarius commented on 2015-08-18 20:51

Okay, PKGREL 7.7.0-2 should function normally.

Rather than downloading the tarball and installing from there, we automate the installation process using pip to ensure necessary dependencies are pulled down. I'm not *quite* sure why this was failing with the tarball from PyPI (same thing, right?), but running the contained setup.py from the PKGBUILD was ignoring certain dependencies Sentry needed.

Either way, it probably doesn't matter. I've long been considering automating the installation via pip but needed something of a kick to do so.

Enjoy.

zancarius commented on 2015-08-18 20:36

The current PKGREL (7.7.0-1) is broken. I'm in the process of figuring out a solution since the PyPI package refuses to install all of the appropriate dependencies. (I have a better idea in mind than the current method of distribution, but it requires some testing first.)

zancarius commented on 2015-07-25 20:16

The Sentry 7.6.x branch is no longer linked from Sentry's PyPI landing page likely due to some of the requirements listed in the project's CHANGES [1]. The problem is, I've since updated this package to v7.6.0.

Since I'm not interested in maintaining two different versions of Sentry in the AUR, and neither am I interested in downgrading the package (the intent is to follow the latest version available), I want you to be mindful of this particular quote from the CHANGES file before upgrading:

> This releases entirely removes Access Groups. If you're upgrading
> form [sic] an installation that had yet to migrate away from this
> system you should first upgrade to a previous version, run the
> migration wizard, and then continue the upgrade.

If this applies to you, you may need to manually upgrade sentry (using pip) before upgrading to the latest version in the AUR:

$ cd /opt/sentry
$ source ./bin/activate
$ sudo pip install --upgrade sentry==7.5.6

(It might be necessary to substitute the version, 7.5.6, with later versions of the Sentry 7.5.x branch as appropriate.)

If this does not apply to you, continue your upgrade as per usual. In most cases, you should be able to upgrade from the previous version (7.5.4) without trouble (I did).

[1] https://github.com/getsentry/sentry/blob/7.6.2/CHANGES

zancarius commented on 2015-03-22 22:40

Updated to Sentry 7.4.1. Sorry about the delay. I don't have my version check script running periodically and haven't gotten around to fix it.

Here's a couple of things I've observed that may be worth taking note of:

Be aware that the upgrade process will now complain if you haven't set SENTRY_ADMIN_EMAIL. It doesn't do any harm, but now is probably a good time to set this configuration if you haven't already. If the Sentry developers think it's important enough to warn about, it's probably important enough to configure!

Also, note that the package dependencies should probably include OpenSSL. I haven't added that to the PKGBUILD yet, but then most systems will probably have it installed anyway...

Unfortunately, one of the side effects of building against OpenSSL means that if you're building or planning to build Sentry for mass deployment, you must ensure you have ABI compatible versions of OpenSSL between your build host and all of your targets. If not, you'll receive something like "cffi.ffiplatform.VerificationError" during start. This will even affect the virtualenv once you've upgraded Sentry (and you won't be able to run pip from there until you do, if you have other packages you want to add to Sentry).

Make sure you've also upgraded pip and setuptools to their latest versions.

Cheers, folks.

codekoala commented on 2015-02-06 05:00

Very nice work on this. So very thorough!