Package Details: sentry 9.1.2-1

Git Clone URL: https://aur.archlinux.org/sentry.git (read-only)
Package Base: sentry
Description: Python-based realtime logging and aggregation server.
Upstream URL: http://pypi.python.org/pypi/sentry
Licenses: BSD
Submitter: zancarius
Maintainer: zancarius
Last Packager: zancarius
Votes: 13
Popularity: 0.138625
First Submitted: 2012-11-04 17:15
Last Updated: 2019-08-31 02:03

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

mitchhentges commented on 2017-05-04 22:25

Yep, I installed and built Sentry on the same machine

zancarius commented on 2017-05-04 22:23

I'll have to look into this later, but I've noticed a couple of things. If uWSGI is trying to pull in an older version of OpenSSL (which it shouldn't, but perhaps there's a reason for it), then it's possible the version Sentry wants is doing the wrong thing here.

uWSGI depends on OpenSSL though to build (you can see this in the community/uwsgi package as well), so I'm not entirely surprised.

Did you build Sentry on the same machine it's installed on?

mitchhentges commented on 2017-05-04 22:15

I'm getting the following error in "sentry-web". I'm running Sentry behind nginx as a proxy, and using HTTPS:

uwsgi: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory

zancarius commented on 2016-11-04 02:41

Bumped to version 8.10.0 (thanks Mitch!).

Beware: Pay very close attention to following the upgrade instructions. File storage settings have moved from sentry.conf.py into config.yml. If you neglect to move these configurations, you may experience breakage.

zancarius commented on 2016-10-06 03:51

This post is to acknowledge a warning related to the Sentry 8.9.0 upgrade:

First, symsynd is now listed as a Sentry dependency [1] and is no longer a separate plugin. As such, I am no longer offering this as a split package with sentry-dsym. If you're coming here because you can't find the sentry-dsym package or because of "exists in filesystem" errors, you'll need to remove sentry-dsym first *before* installing Sentry.

Unfortunately, the inclusion of symsynd now means that Sentry requires LLVM to be installed on the target host. I've included some suggestions in `sentry.install` in the event this is a problem, but it looks like this is the direction upstream is going, so we're going to have to follow suit.

Second, changes to symsynd now require ncurses 5.x. Unfortunately, Arch uses ncurses 6.x, so we currently have to pull an external lib from the AUR to install ncurses 5.x support (ncurses5-compat-libs). I don't have much confidence that symsynd will be updated to ncurses 6 any time soon, so if time permits, I may investigate other options.

If you experience problems with this release, it's likely they may be due to missing libraries or other dependencies I've missed. Feel free to submit a ticket on any of the repositories listed here [2].

[1] https://github.com/getsentry/sentry/blob/8.9.0/setup.py#L133
[2] https://github.com/zancarius/archlinux-pkgbuilds

zancarius commented on 2016-10-05 06:00

Got the outdated notification. I'll update to 8.9.0 sometime tomorrow or tomorrow evening (UTC-6).

zancarius commented on 2016-09-08 06:22

Updated to version 8.8.0. Thanks for the notification!

As always, report PKGBUILD bugs on my PKGBUILDs repository [1].

I now have mirrors configured elsewhere (see the README), so if you'd rather avoid GitHub or have a preference elsewhere, feel free to pick the host that suits your needs best and report bugs there.

[1] https://github.com/zancarius/archlinux-pkgbuilds

zancarius commented on 2016-06-10 05:24

Added.

libxml2 is probably also required as well, strictly speaking, it's just that pulling in libxslt also installs libxml2.

For completeness sake, I've updated the makedepends to include both. Apparently the notion of adding it to the split package depends array never fully percolated to the top when I was considering makedepends.

Good catch, thanks!

Ahti333 commented on 2016-06-10 04:40

The makedepends of the PKGBUILD should include libxslt as well. The python2-lxml egg won't build without it.

zancarius commented on 2016-06-06 17:49

Thanks Mitch!

I appreciate your feedback and help!