Package Details: semgrep-bin 0.59.0-1

Git Clone URL: https://aur.archlinux.org/semgrep-bin.git (read-only, click to copy)
Package Base: semgrep-bin
Description: Fast and syntax-aware semantic code pattern search for many languages: like grep but for code
Upstream URL: https://github.com/returntocorp/semgrep
Keywords: code grep
Licenses: LGPL2.1
Provides: semgrep
Submitter: aloxaf
Maintainer: aloxaf
Last Packager: aloxaf
Votes: 3
Popularity: 0.012783
First Submitted: 2020-05-23 02:08
Last Updated: 2021-07-21 04:58

Latest Comments

« First ‹ Previous 1 2

aloxaf commented on 2020-09-19 14:52

@dkasak Thanks again!

How about now?

dkasak commented on 2020-09-19 12:30

@aloxaf Unfortunately, I just realized this doesn't fix the issue.

The problem is that semgrep is actually semgrep-core + the semgrep Python package from PyPI. Both are needed for semgrep to work correctly, as the Python package actually provides semgrep, the high-level user-facing CLI tool. Yet upstream releases seem to only package semgrep-core in the Github releases.

This means this package is not a correct package for semgrep currently. If you'd like some help, I can try to throw together a correct PKGBUILD when I get the time, unless you get to it sooner.

aloxaf commented on 2020-09-15 11:47

@dkasak Fixed. Thanks for reporting.

dkasak commented on 2020-09-11 13:29

The file /usr/bin/semgrep installed by the package is a broken symlink to a non-existent file /usr/lib/semgrep-files/semgrep.