Package Details: seexpr1-2-doc 2.11-1

Git Clone URL: https://aur.archlinux.org/seexpr1-2.git (read-only, click to copy)
Package Base: seexpr1-2
Description: An embeddable expression evaluation engine
Upstream URL: http://www.disneyanimation.com/technology/seexpr.html
Licenses: custom:APACHE
Submitter: bartus
Maintainer: bartus
Last Packager: bartus
Votes: 0
Popularity: 0.000000
First Submitted: 2019-09-01 11:19
Last Updated: 2019-09-01 11:19

Dependencies (6)

Required by (0)

Sources (2)

Latest Comments

berilac commented on 2020-03-15 21:09

@bartus tried building in clean chroot, both with makechrootpkg and extra_x86-64 (as suggested below) but it fails with the following:

[ 98%] Linking CXX executable segraph
make[2]: Leaving directory '/build/seexpr1-2/src/SeExpr/build'
[ 98%] Built target segraph
make[1]: Leaving directory '/build/seexpr1-2/src/SeExpr/build'
make: *** [Makefile:130: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...

If there's anything I can provide to help, let me know

yoarch commented on 2020-02-29 14:24

Sorry, I gave up and don't have the time right now to try it.

bartus commented on 2020-02-29 13:14

@yoarch: Can't reproduce, did you install all dependencies? could you try building with extra_x86-64

extra-x86_64-build -r /tmp/root -- \ 
-I qt4-4.8.7-31-x86_64.pkg.tar.zst \
-I python2-sip-4.19.19-1-x86_64.pkg.tar.zst \
-I python2-sip-pyqt4-4.19.19-1-x86_64.pkg.tar.zst \ 
-I pyqt4-common-4.12.3-4-x86_64.pkg.tar.zst \
-I python2-pyqt4-4.12.3-4-x86_64.pkg.tar.zst

yoarch commented on 2020-02-17 15:59

Hi,

I can not build it, getting:

sip: Unable to find file "QtGui/QtGuimod.sip"
make[2]:  [src/SeExprEditor/CMakeFiles/expreditor.dir/build.make:62: src/SeExprEditor/sipexpreditorpart0.cpp] Error 1
make[2]: Leaving directory '/tmp/yaourt-tmp/aur-seexpr1-2/src/SeExpr/build'
make[1]:  [CMakeFiles/Makefile2:321: 
src/SeExprEditor/CMakeFiles/expreditor.dir/all] Error 2
make[1]: Leaving directory '/tmp/yaourt-tmp/aur-seexpr1-2/src/SeExpr/build'
make: *** [Makefile:130: all] Error 2

/usr/share/sip/PyQt4/QtGui/QtGuimod.sip is in my file system.

Can not find a way to solve it.

tercio commented on 2020-01-10 06:24

Hi, I ask you to replace the dependency "python2-sip" on PKGBUILD with "python2-sip-pyqt4", because the first package no longer exists.