Package Details: sdbus-cpp-git 2:0.8.3.33.r261.d20210622.e16ffb1-1

Git Clone URL: https://aur.archlinux.org/sdbus-cpp-git.git (read-only, click to copy)
Package Base: sdbus-cpp-git
Description: sdbus-c++ is a high-level C++ D-Bus library for Linux designed to provide expressive, easy-to-use API in modern C++
Upstream URL: https://github.com/Kistler-Group/sdbus-cpp
Licenses: LGPL2.1, custom:sdbus-c++ LGPL Exception 1.0
Conflicts: sdbus-cpp, sdbus-cpp-, sdbus-cpp-git
Provides: sdbus-cpp=0.8.3.33.r261.d20210622.e16ffb1, sdbus-cpp-=0.8.3.33.r261.d20210622.e16ffb1, sdbus-cpp-git=0.8.3.33.r261.d20210622.e16ffb1
Submitter: cirk2
Maintainer: cirk2
Last Packager: cirk2
Votes: 0
Popularity: 0.000000
First Submitted: 2019-11-29 23:39
Last Updated: 2021-07-09 06:56

Required by (5)

Sources (1)

Latest Comments

dreieck commented on 2021-07-08 10:12

Needs expat as dependency:

namcap says: E: Dependency expat detected and not included (libraries ['usr/lib/libexpat.so.1'] needed in files ['usr/bin/sdbus-c++-xml2cpp'])

dreieck commented on 2021-07-08 10:11

license-entry LGPLv2.1 should be LGPL2.1 (as this one is the name present in /usr/share/licenses/common/).

Thanks for maintaining!

dreieck commented on 2021-07-08 09:49

Please change the versioning scheme such that the software's notion of version is the first part of $pkgver. (Cf. PKGBUILD-guidelines, see also VCS packages guidelines.)

Version 0.8.3 is the latest release.

So you pkgver() should parse the release to generate something like (currently) 0.8.3+r261.e16ffb1 or so. git describe --tags in this case gives already the needed information, the file CMakeLists.txt also has it.

You can see package sdbus-cpp-nosystemd-git as an example.

This is important to compare the versions of the packages sdbus-cpp-git and sdbus-cpp.

Also, you then can also (and I would find it helpful if you do) add ="${pkgver}"' to theprovides=('sdbus-cpp')`-entry.

(Don't forget to increment $epoch when changing versioning scheme.)

Thanks for maintaining!

vsemyonoff commented on 2020-02-02 19:31

Please add doxygen to build time dependency list because makepkg fails without it or disable documentation generation while building package.