Package Details: scribus-stable 1.4.8-1

Git Clone URL: https://aur.archlinux.org/scribus-stable.git (read-only, click to copy)
Package Base: scribus-stable
Description: scribus-stable
Upstream URL: http://www.scribus.net
Licenses: GPL, LGPL
Conflicts: scribus-svn
Provides: scribus-stable
Submitter: benoitldr
Maintainer: benoitldr
Last Packager: benoitldr
Votes: 1
Popularity: 0.000245
First Submitted: 2020-01-15 08:32
Last Updated: 2021-02-04 21:32

Latest Comments

haawda commented on 2021-01-23 21:36

This needs qt4 to build, and cmake variables musst be adjusted.

# Maintainer: Benoit Landrieu (ben@gresille.org)

pkgname=scribus-stable
pkgver=1.4.8
pkgrel=1
pkgdesc="Desktop publishing program - old stable version"
arch=('i686' 'x86_64')
license=('GPL' 'LGPL')
url="http://www.scribus.net"
depends=('hunspell' 'podofo' 'libcups' 'python' 'python2' 'cairo' 'desktop-file-utils'
     'qt4' 'hyphen')
makedepends=('cmake')
optdepends=('lib2geom: for mesh distortion')
conflicts=('scribus')
provides=('scribus')
source=("https://netix.dl.sourceforge.net/project/scribus/scribus/1.4.8/scribus-1.4.8.tar.gz")
md5sums=('6246cadc3d0a6dfc0119926eb7e7dcda')
options=('!emptydirs')

build() {
  cd "${pkgname%-stable}-$pkgver"
  cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr \
    -DCMAKE_INSTALL_DATAROOTDIR:PATH=/usr/share \
    -DCMAKE_LIBRARY_PATH:PATH=/usr/lib \
    -DCMAKE_SKIP_RPATH=ON \
    -DCMAKE_BUILD_WITH_INSTALL_RPATH:BOOL=FALSE .
  make
}

package() {
  cd "${pkgname%-stable}-$pkgver"
  make DESTDIR="$pkgdir/" install
}

waldbaer59 commented on 2021-01-22 19:42

The package doesn't build correctly.

[code]CMake Error at /usr/share/cmake-3.19/Modules/FindQt4.cmake:1314 (message): Found unsuitable Qt version "5.15.2" from /usr/bin/qmake, this code requires Qt 4.x Call Stack (most recent call first): CMakeLists.txt:587 (FIND_PACKAGE)[/code]

damarusama commented on 2020-08-04 19:19

I'm getting a: Could not find PKGDEST for scribus-stable on yay v10.0.3 - libalpm v12.0.2 Je fais un build manuel pour le moment pour voir comment je peux debugger.

benoitldr commented on 2020-04-26 19:18

Je suis entrain de travailler sur une version aur car je l'ai installé en dur chez moi car en effet il faut scribus 1.4.8 car les fichiers 1.5.5 ne sont pas ouvrables pour l'instant avec la version testing dans [community] ça devrait être fait ce soir désolé pour le retard, je ne suis pas un pro du package sous aur... @bateausurleau

bateausurleau commented on 2020-03-27 09:05

En lançant l'installation de la version 1.4.8, juste à la fin, j'ai obtenu cela : [ 100%] Linking CXX shared module libscriptplugin.so make[2] : on quitte le répertoire « /var/tmp/pamac-build-julien/scribus-stable/src/scribus-1.4.8 » [100%] Built target scriptplugin make[1] : on quitte le répertoire « /var/tmp/pamac-build-julien/scribus-stable/src/scribus-1.4.8 » ==> Lancement de check()… make: *** Aucune règle pour fabriquer la cible « check ». ==> ERREUR : Une erreur s’est produite dans check(). Abandon…

Question : comment puis-je résoudre ce problème ? J'ai vraiment besoin de la version stable de Scribus (1.4.7 ou 1.4.8) et j'aimerai rester sous Manjaro et non retourner sous Mint.

Merci pour le temps consacré !

benoitldr commented on 2020-01-27 10:49

I needed this software but I am still working on it for working in aur...

slot commented on 2020-01-27 08:45

I get this error: CMake Error at /usr/share/cmake-3.16/Modules/FindQt4.cmake:1314 (message): Found unsuitable Qt version "5.14.0" from /usr/bin/qmake, this code requires Qt 4.x