Package Details: screencloud 1.5.3-1

Git Clone URL: https://aur.archlinux.org/screencloud.git (read-only, click to copy)
Package Base: screencloud
Description: An easy to use screenshot sharing application
Upstream URL: https://github.com/olav-st/screencloud/
Licenses: GPL
Submitter: lybin
Maintainer: dbermond
Last Packager: dbermond
Votes: 42
Popularity: 0.036076
First Submitted: 2012-09-24 12:40
Last Updated: 2020-10-28 22:24

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

dbermond commented on 2018-08-14 01:26

Temporarily switched to python2 due to an upstream build error with python 3.7.

MobiusReactor commented on 2018-08-10 03:22

@fosskers, you can get around those errors by updating the quazip package. If you're using antergos, the version in the antergos repo is outdated, but a more up-to-date version can be found in the arch community repo if you temporarily disable the antergos repo. However, you'll run into other issues if you've updated to python 3.7 as well.

There's been a bunch of new commits in the upstream repo lately though, so hopefully we'll get a new release soon that fixes some of these issues.

fosskers commented on 2018-06-22 16:22

Trying to build, I get:

==> ERROR: options array contains unknown option '!optipng' ==> ERROR: options array contains unknown option '!upx'

Looking at the PKGBUILD, so are indeed in there:

options=('strip' 'docs' 'libtool' '!staticlibs' 'emptydirs' 'zipman' 'purge' '!optipng' '!upx' '!debug' '!emptydirs')

Maybe makepkg doesn't support those anymore?

After I remove those options the build starts, but the code itself fails to compile. Here are just two of the errors:

/usr/include/quazip5/crypt.h:68:81: error: expected ‘,’ or ‘...’ before ‘’ token static void init_keys(const char passwd,unsigned long* pkeys,const z_crc_t FAR * pcrc_32_tab)

/usr/include/quazip5/crypt.h: In function ‘void init_keys(const char, long unsigned int, int)’: /usr/include/quazip5/crypt.h:74:27: error: ‘pcrc_32_tab’ was not declared in this scope update_keys(pkeys,pcrc_32_tab,(int)*passwd);

clofresh commented on 2018-02-14 17:28

FYI I think the screencloud service shut down (http://downforeveryoneorjustme.com/screencloud.net), but you can still use this client to upload to dropbox, imgur or locally.

bcc commented on 2017-06-13 11:31

==> Validating source files with sha256sums...
screencloud-1.3.1.tar.gz ... FAILED
==> ERROR: One or more files did not pass the validity check!

lybin commented on 2017-06-09 19:04

@zerophase, fixed.

zerophase commented on 2017-06-08 23:14

After the pythonqt update I'm getting this error when trying to reinstall.

CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
PYTHONQT_LIBRARY (ADVANCED)
linked by target "screencloud" in directory /tmp/makepkg/screencloud/src/screencloud-1.3.1

blitz commented on 2017-02-02 06:58

@amadej
See the comment @AlfredoRamos on 2016-10-11 18:40 and install/update pythonqt.

amadej commented on 2017-01-30 20:02

libpython3.5m.so.1.0 mnissing error

...
[100%] Linking CXX executable screencloud
/usr/bin/ld: warning: libpython3.5m.so.1.0, needed by /usr/lib/gcc/x86_64-pc-linux-gnu/6.3.1/../../../../lib/libPythonQt.so, not found (try using -rpath or -rpath-link)
/usr/lib/gcc/x86_64-pc-linux-gnu/6.3.1/../../../../lib/libPythonQt.so: undefined reference to `PyType_IsSubtype'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.3.1/../../../../lib/libPythonQt.so: undefined reference to `PyExc_RuntimeError'
/usr/lib/gcc/x86_64-pc-linux-gnu/6.3.1/../../../../lib/libPy....
...

The issue can be resolved by

# ln -s /usr/lib/libpython3.so /usr/lib/libpython3.5m.so.1.0

however, I do not really like such "tactics" for everyday tools

BlazWin commented on 2016-12-25 02:15

Having the same problem as @tate on GNOME 3.22. Opened issue https://github.com/olav-st/screencloud/issues/257