Package Details: scipoptsuite 7.0.1-1

Git Clone URL: https://aur.archlinux.org/scipoptsuite.git (read-only, click to copy)
Package Base: scipoptsuite
Description: Toolbox for generating and solving optimization problems (with Parallel Processing)
Upstream URL: https://scip.zib.de
Keywords: math optimization solver
Licenses: LGPL3, custom:ZIB Academic License
Provides: gcg=3.0.3, gmp=6.1.2, papilo=1.0.1, scip=7.0.1, soplex=5.0.1, zimpl=3.4.0
Replaces: ziboptsuite
Submitter: the-k
Maintainer: ragouel
Last Packager: ragouel
Votes: 3
Popularity: 0.54
First Submitted: 2017-04-26 10:44
Last Updated: 2020-07-08 18:55

Dependencies (18)

Required by (570)

Sources (1)

Pinned Comments

ragouel commented on 2020-04-14 20:34

Zuse Institute Berlin no longer provides direct links to scipoptsuite, you will have to manually download and put the .tgz file where PKGBUILD is located.

Either move it over

mv ~/Download/scipoptsuite-7.0.0.tgz ~/.cache/yay/scipoptsuite
or link to it
ln -s ~/Download/scipoptsuite-7.0.0.tgz ~/.cache/yay/scipoptsuite

then, cd into ~/.cache/yay/scipoptsuite and run

makepkg -si
to install it.

Assuming you're using yay

Latest Comments

1 2 Next › Last »

ragouel commented on 2020-10-19 18:29

Hello racko, please read the AUR wiki, it states "Packages in the AUR assume that the base-devel group is installed, i.e. they do not list the group's members as build dependencies explicitly." flex and bison are both part of base-devel.

racko commented on 2020-10-19 18:17

sed: can't read /home/racko/.cache/yay/scipoptsuite/pkg/scipoptsuite/usr/include/zimpl/mmlparse2.h: No such file or directory

This was caused by zimpl not being build which was caused by bison not being installed on my machine which was not detected by the PKGBUILD because it is not listed in the depends. The same could have happened with flex. It's not an optdepend because you need to build zimpl for the final sed to work. And you list zimpl=3.4.0 in the provides :)

ragouel commented on 2020-04-14 20:34

Zuse Institute Berlin no longer provides direct links to scipoptsuite, you will have to manually download and put the .tgz file where PKGBUILD is located.

Either move it over

mv ~/Download/scipoptsuite-7.0.0.tgz ~/.cache/yay/scipoptsuite
or link to it
ln -s ~/Download/scipoptsuite-7.0.0.tgz ~/.cache/yay/scipoptsuite

then, cd into ~/.cache/yay/scipoptsuite and run

makepkg -si
to install it.

Assuming you're using yay

dariost commented on 2020-04-14 15:36

Hi, please consider enabling the Task Processing Interface for SCIP, since right now the concurrentopt command gives a "SCIP was compiled without task processing interface. Parallel solve not possible" error

xuiqzy commented on 2019-11-04 09:18

Info for others installing this package and missing something they need, look at the output when building this! I edited the pkgbuild to build version 6.0.2 and got these warnings about missing (optional) dependencies:

CMake Warning at scip/doc/CMakeLists.txt:19 (message):
  Could not find all of doxygen, python, php, and bash in system path, which
  are required for generation of documentation


-- Could NOT find CRITERION (missing: CRITERION_LIBRARY CRITERION_INCLUDE_DIR) 
-- Build shared libraries: ON
-- Build type: Release
-- Found PkgConfig: /usr/bin/pkg-config (found version "1.6.3") 
-- Could NOT find GSL: Found unsuitable version "", but required is at least "2.0" (found GSL_INCLUDE_DIR-NOTFOUND)
-- Could NOT find CLIQUER (missing: CLIQUER_INCLUDE_DIRS CLIQUER_LIBRARIES) 
-- Could NOT find BLISS (missing: BLISS_INCLUDE_DIR BLISS_INCLUDE_DIRS BLISS_LIBRARIES BLISS_DEFINITIONS) 
-- The following OPTIONAL packages have been found:

 * ZLIB
 * Readline
 * ZIMPL
 * PkgConfig

-- The following REQUIRED packages have been found:

 * BISON
 * FLEX
 * SOPLEX
 * GMP
 * SCIP

-- The following OPTIONAL packages have not been found:

 * IPOPT (required version >= 3.12.0)
 * Criterion
 * GSL (required version >= 2.0)
 * CLIQUER
 * HMETIS
 * BLISS

joelsc commented on 2019-02-24 17:27

I don't have to maintain this anymore. Anyone interested feel free to adopt it :)

danielfm123 commented on 2019-02-24 16:29

can we add ug and gcg on this package? ug package is broken...

Viech commented on 2018-08-10 16:20

6.0.0 was released: http://scip.zib.de/doc-6.0.0/html/RN60.php

Viech commented on 2018-03-15 14:35

Hello, just a reminder that the package is out-of-date as 5.0.1 was released. The necessary update is merely setting the version to 5.0.1 and adjusting the sha256sum accordingly.

Viech commented on 2017-12-15 19:15

Thank you, my package python-pyscipopt is functioning now.