Package Details: scilab 6.0.2-1

Git Clone URL: https://aur.archlinux.org/scilab.git (read-only)
Package Base: scilab
Description: A scientific software package for numerical computations.
Upstream URL: https://www.scilab.org
Licenses: GPL2, BSD, custom:CeCILL
Submitter: td123
Maintainer: eolianoe
Last Packager: eolianoe
Votes: 71
Popularity: 0.008897
First Submitted: 2011-12-07 20:36
Last Updated: 2019-03-04 20:28

Dependencies (37)

Sources (7)

Pinned Comments

Potomac commented on 2018-06-27 01:53

scilab 6 has a bug related to jogl jar library, if mesa version is >= 17.2 then scilab will be unable to use graphic hardware acceleration, no graph plotting,

http://forum.jogamp.org/Mesa-17-2-0-renderer-driver-name-change-error-causes-GLProfile-not-mapped-initialization-error-td4038176.html

in the console we can read these error logs : javax.media.opengl.GLException: X11GLXDrawableFactory - Could not initialize shared resources for :0 at jogamp.opengl.x11.glx.X11GLXDrawableFactory$SharedResourceImplementation.createSharedResource(X11GLXDrawableFactory.java:317) at jogamp.opengl.SharedResourceRunner.run(SharedResourceRunner.java:295) at java.lang.Thread.run(Thread.java:748) Caused by: java.lang.NullPointerException at jogamp.opengl.GLContextImpl.makeCurrent(GLContextImpl.java:625) at jogamp.opengl.GLContextImpl.makeCurrent(GLContextImpl.java:539) at jogamp.opengl.x11.glx.X11GLXDrawableFactory$SharedResourceImplementation.createSharedResource(X11GLXDrawableFactory.java:293) ... 2 more

the solution is to build scilab with a beta version of jogl (2.3.3), or to disable gpu hardware acceleration :

export LIBGL_ALWAYS_SOFTWARE=1

eolianoe commented on 2017-05-03 12:22

In order order to update (and/or build), you may need to uninstall scilab then build it and finally reinstall it to avoid conflicts between the two versions.

For now, scilab fails to run when launched from outside a terminal.

Latest Comments

« First ‹ Previous ... 3 4 5 6 7 8 9 10 11 12 13 ... Next › Last »

leonardojc commented on 2017-06-10 16:25

Now that java-batik was updated to version 1.9, XCos doesn't work anymore, throwing a "missing version 1.7" error

haawda commented on 2017-06-03 16:23

When I start scilab, I get a warning:

Warning: Could not find Java package '/usr/share/scilab//thirdparty/ecj.jar'.
Some problems during the loading of the Java libraries occurred.
This could lead to inconsistent behaviours.
Please check SCI/etc/classpath.xml.

This can be avoided by
a) providing that file in the scilab package or
b) adjusting the classpath.xml file to point to /usr/share/java/ecj.jar (that is the place wher the eclipse-ecj package provides ecj.jar)

eolianoe commented on 2017-05-31 10:57

@simona: I'm not fluent with italian but you should fix the dependency.

simona commented on 2017-05-31 10:09

==> Continuare la compilazione di scilab [S/n]
==> ------------------------------------------
==>
==> Compilazione e installazione del pacchetto
==> Installa o compila le dipendenze mancanti per scilab:
risoluzione delle dipendenze in corso...
ricerca dei pacchetti in conflitto in corso...
:: gcc-libs e gcc-libs-multilib vanno in conflitto. Vuoi rimuovere gcc-libs-multilib? [s/N]
errore: sono stati rilevati dei conflitti irrisolvibili tra i pacchetti
errore: impossibile eseguire l'operazione richiesta (dipendenze in conflitto)
:: gcc-libs e gcc-libs-multilib vanno in conflitto

eolianoe commented on 2017-05-22 08:26

@mcrai: first you should try to compile it with pure makeppkg, then if it's still failing you can send me the full build log to see if there is a difference with mine. However, I cannot test Arch derivatives.

ps: comments are editable.

mcrai commented on 2017-05-21 16:56

@eolianoe: two weeks and many updates later: after a somewhat lengthy install process I get the same error messages.
Maybe worth to mention: I am trying to install under Linux Manjaro using the Yaourt tool from within Octopi. Don't know if this is of relevance, do not know alternatives, either.
Other than that, I do not know what is special about my config. How can I dig in deeper into the problem?

Help would be much appreciated.

eolianoe commented on 2017-05-17 15:17

@Li33f: no idea, it seems that the host is definitively down, but you should make that comment on the page of the javahelp2 package [a].

[a] https://aur.archlinux.org/packages/javahelp2/

Li33f commented on 2017-05-17 15:01

Good afternoon,

I encounter a failure during this installation of scilab, javahelp2 svn seems to be unavailable do you have an idea on how to fix this ?



"Échec lors du téléchargement du dépôt javahelp2 svn"

chavezgt commented on 2017-05-13 10:53

Missing dependency bwidget. The package bwidget is required by the Axes Editor, of the Plot Window. Please add bwidget as a required dependency.

eolianoe commented on 2017-05-10 11:24

@mcrai: building fine here (even in a clean chroot) so you may have something special in your config.

@ye_k: never tested to link with C++ or Java you should ask to the users mailing list