Package Details: scilab 6.0.2-1

Git Clone URL: https://aur.archlinux.org/scilab.git (read-only)
Package Base: scilab
Description: A scientific software package for numerical computations.
Upstream URL: https://www.scilab.org
Licenses: GPL2, BSD, custom:CeCILL
Submitter: td123
Maintainer: eolianoe
Last Packager: eolianoe
Votes: 71
Popularity: 0.016727
First Submitted: 2011-12-07 20:36
Last Updated: 2019-03-04 20:28

Dependencies (37)

Sources (7)

Pinned Comments

Potomac commented on 2018-06-27 01:53

scilab 6 has a bug related to jogl jar library, if mesa version is >= 17.2 then scilab will be unable to use graphic hardware acceleration, no graph plotting,

http://forum.jogamp.org/Mesa-17-2-0-renderer-driver-name-change-error-causes-GLProfile-not-mapped-initialization-error-td4038176.html

in the console we can read these error logs : javax.media.opengl.GLException: X11GLXDrawableFactory - Could not initialize shared resources for :0 at jogamp.opengl.x11.glx.X11GLXDrawableFactory$SharedResourceImplementation.createSharedResource(X11GLXDrawableFactory.java:317) at jogamp.opengl.SharedResourceRunner.run(SharedResourceRunner.java:295) at java.lang.Thread.run(Thread.java:748) Caused by: java.lang.NullPointerException at jogamp.opengl.GLContextImpl.makeCurrent(GLContextImpl.java:625) at jogamp.opengl.GLContextImpl.makeCurrent(GLContextImpl.java:539) at jogamp.opengl.x11.glx.X11GLXDrawableFactory$SharedResourceImplementation.createSharedResource(X11GLXDrawableFactory.java:293) ... 2 more

the solution is to build scilab with a beta version of jogl (2.3.3), or to disable gpu hardware acceleration :

export LIBGL_ALWAYS_SOFTWARE=1

eolianoe commented on 2017-05-03 12:22

In order order to update (and/or build), you may need to uninstall scilab then build it and finally reinstall it to avoid conflicts between the two versions.

For now, scilab fails to run when launched from outside a terminal.

haawda commented on 2013-02-26 16:34

Adopted and updated. But a no from me for the nogui-version.

techlive commented on 2013-02-26 16:23

@StefanHusmann Orphaned, there is also a nogui version: https://aur.archlinux.org/packages/scilab-nogui, maybe consider adopt it too.

haawda commented on 2013-02-26 16:20

techlive, I did not activate notifications for this package. Now I have. If you like to orphan it again, I will take it.

shanipribadi commented on 2013-02-05 16:11

I had just successfully built the package for scilab 5.4.0 with the PKGBUILD given by @StefanHusmann with the addition of umfpack.
To compile scilab 5.4.0 with umfpack from suitesparse you need to add
LIBS='-lcholmod -lcolamd -lsuitesparseconfig' before the configure line.
The better way might be by adding a patch that modifies scilab-5.4.0/m4/umfpack.m4 and regenerate the config files (autoconf etc).

techlive commented on 2012-12-08 01:46

@StefanHusmann There is also a nogui version: https://aur.archlinux.org/packages/scilab-nogui, may be consider adopt it too.

techlive commented on 2012-12-08 01:43

@StefanHusmann I have disowned package, feel free to adopt it.

haawda commented on 2012-12-07 20:26

I have a PKGBUILD for 5.4.0, which uses the thirdparty tarballs from upstream instead of the AUR packages for the various java stuff.

http://paste.pound-python.org/show/28272/

Install-file:
http://paste.pound-python.org/show/28273/

Anonymous comment on 2012-02-13 05:36

jrosetta problem fixed

checking jgraphx... /usr/share/java/jgraphx//jgraphx.jar
checking minimal version (1.4.1.0) of jgraphx... configure: error: Wrong version of jgraphx. Expected exact version 1.4.1.0. Found 1.8.0.6
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build scilab.


OK so we can't do the >=1_4_1_0 change, going to try convincing it to use http://aur.archlinux.org/packages.php?ID=55226&detail=1 instead

Anonymous comment on 2012-02-12 20:34

Had to change "jgraphx=1_4_1_0" to "jgraphx", run into a problem with jrosetta now, something about not being able to extract .jars properly:
-> Extracting jrosetta-engine-1.0.4.jar with bsdtar
META-INF/maven/: Can't remove already-existing dir
META-INF/maven/com.artenum.jrosetta/: Can't remove already-existing dir
bsdtar: Error exit delayed from previous errors.
==> ERROR: Failed to extract jrosetta-engine-1.0.4.jar
Aborting...
==> ERROR: Makepkg was unable to build jrosetta.

Also, Scilab 5.3.3 is now out.

techlive commented on 2011-12-23 19:20

jlatexmath-fop java-avalon-framework should be add as dependcy.
/usr/share/scilab/etc/classpath.xml need to be adjusted.
grapphx should be >= 1_4_1_0