Package Details: samtools 1.14-1

Git Clone URL: https://aur.archlinux.org/samtools.git (read-only, click to copy)
Package Base: samtools
Description: tools for manipulating next-generation sequencing data
Upstream URL: http://www.htslib.org/
Licenses: custom
Submitter: Vrob
Maintainer: r6eve
Last Packager: r6eve
Votes: 29
Popularity: 0.018885
First Submitted: 2009-11-04 21:48
Last Updated: 2021-10-23 00:32

Dependencies (2)

Required by (11)

Sources (1)

Latest Comments

1 2 3 4 5 Next › Last »

viralstitch commented on 2021-07-31 15:54

I'm sorry for not getting back to you sooner. I no longer have time to maintain the package. Anyone is welcome to pick it up.

zethson commented on 2021-07-13 13:18

Installation fails because 7 tests are failing. I would appreciate a fix.

Thanks!

viralstitch commented on 2020-09-23 00:13

Thanks for the comment. I've pushed a pkgrel update with the new checksums. They changed at some point today. These files worked for me this morning.

Rhinoceros commented on 2020-09-22 23:17

The checksum is wrong. This worked for me:

sha256sums=('e283cebd6c1c49f0cf8a3ca4fa56e1d651496b4d2e42f80ab75991a9ece4e5b6')

iosonofabio commented on 2020-03-30 00:06

Same problem here, had this for a few months already. 1 test fails during the installation and that breaks the build process.

Anything we can do about this?

Thank you

linearleopard commented on 2020-03-03 21:56

Hello, thank you for maintaining the package.

You do a great job.

But today I had to reinstall the package and met with unexpected behavior: samtools didn't install due to some failing tests. But when I've started investigate it, I found out that that tests were failing due to perl in their pipelines, which wrote a message about unspecified locale. :)

I think that some warning in 3rd party software shouldn't prevent the package from installation.

Regards.

Rhinoceros commented on 2019-12-18 20:56

Oops sorry @viralstitch. Missed it somehow. Thank you!

viralstitch commented on 2019-12-18 15:32

If you've installed samtools-1.10-2, you'll need to upgrade to samtools-1.10-3 before upgrading htslib in order to solve the dependency issue.

Let me know if there are any other issues. Thanks!

Rhinoceros commented on 2019-12-18 08:55

@viralstitch Did you mean to depend on htslib=1.10 or htslib>=1.10? Currently htslib is 1.10.1, so samtools cannot be installed.

viralstitch commented on 2019-12-10 16:15

I think this is an issue with htslib changing its type names. I've updated the package to require htslib=1.10