Package Details: sakis3g 0.2.0e-7

Git Clone URL: https://aur.archlinux.org/sakis3g.git (read-only)
Package Base: sakis3g
Description: An all-in-one script for connecting with 3G
Upstream URL: https://github.com/Trixarian/sakis3g-source
Keywords: 3G modem
Licenses: GPL2
Submitter: None
Maintainer: bjo
Last Packager: bjo
Votes: 19
Popularity: 0.000000
First Submitted: 2012-05-05 13:35
Last Updated: 2018-12-11 09:49

Dependencies (11)

Required by (0)

Sources (2)

Latest Comments

« First ‹ Previous 1 2 3

Anonymous comment on 2012-08-14 16:38

I have the same as nickoe (Available USB options are: 1. file 2. matches)

After debugging sakis3g, I get this:

[16675] [18:21:15] [usb_connected_devices] Fetching connected USB devices by using "/sys/bus/usb/devices".
[16675] [18:21:15] [usb_connected_devices] Connected USB devices are:
Binary file 1-1/idProduct matches Binary file 1-1/idVendor matches Binary file 1-1/product matches
Binary file 1-8/idProduct matches Binary file 1-8/idVendor matches Binary file 1-8/product matches
Binary file usb1/idProduct matches Binary file usb1/idVendor matches Binary file usb1/product matches
Binary file usb2/idProduct matches Binary file usb2/idVendor matches Binary file usb2/product matches
Binary file usb3/idProduct matches Binary file usb3/idVendor matches Binary file usb3/product matches
Binary file usb4/idProduct matches Binary file usb4/idVendor matches Binary file usb4/product matches
Binary file usb5/idProduct matches Binary file usb5/idVendor matches Binary file usb5/product matches
[16675] [18:21:16] [usb_connected_modems] No plugged modems found.

My modem is
Bus 001 Device 006: ID 12d1:1c05 Huawei Technologies Co., Ltd. E173s 3G broadband stick (modem on)

ingamedeo commented on 2012-08-14 12:16

sakis3g non working (Segmentation Fault) because Zenity has a bug: https://bugs.launchpad.net/archlinux/+source/zenity/+bug/968534

Fix Zenity or install from AUR zenity-gtk2

illektr1k commented on 2012-07-27 07:16

@nickoe: Your modem probably has multiple modes, eg a flashdrive mode which contains setup software for Windows/Mac. I had to install usb_modeswitch as per https://wiki.archlinux.org/index.php/USB_3G_Modem#Mode_switching then unplug/replug for it to be properly picked up.

Anonymous comment on 2012-07-26 11:11

nickoe, sorry for late answer, haven't been around lately. Anyway, I had the exact same problem (I don't know what caused it) but I solved it by specifying CUSTOM_TTY in the configuration file; this is how mine looks like:

OTHER=CUSTOM_TTY
CUSTOM_TTY="/dev/ttyUSB0"
APN=CUSTOM_APN
CUSTOM_APN="general.t-mobile.uk"
APN_USER="t-mobile"
APN_PASS="tm"

When you run sakis3g you can specify on the command line as well:

sakis3g 'OTHER=CUSTOM_TTY CUSTOM_TTY="/dev/ttyUSB0"'

Or you can just run it interactively and specify it there:

sakis3g --interactive

nickoe commented on 2012-07-10 14:38

jwobble, thank you for the PKGBUILD, but I have problems with sakis3g now. It has worked for a few months ago. I get this when I was supposed to see the USB devides connected to my machine. Do you know why and how to fix?

Please select USB modem

Select USB device that provides modem capabilities.

Available options are:
1. file
2. matches
3. file
4. matches
5. file
6. matches
7. file
8. matches
9. file
10. matches
11. file
12. matches
13. file
14. matches
15. file
16. matches
17. file
18. matches
0. Cancel
You can automate this selection by setting USBMODEM variable.
Enter "*" to discover how.

Please use numbers 0-18 to perform your selection:

SanskritFritz commented on 2012-05-24 14:58

Very nice, thank you. That one vote is mine :)