Package Details: saga-gis 7.5.0-2

Git Clone URL: https://aur.archlinux.org/saga-gis.git (read-only, click to copy)
Package Base: saga-gis
Description: A Geographic Information System (GIS) software with immense capabilities for geodata processing and analysis.
Upstream URL: http://www.saga-gis.org
Keywords: GeoSpatial GIS
Licenses: GPL3
Submitter: None
Maintainer: geosam
Last Packager: geosam
Votes: 11
Popularity: 0.000000
First Submitted: 2007-07-16 01:57
Last Updated: 2020-01-09 21:45

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

saultdon commented on 2014-01-12 22:20

I've got SAGA 2.1.1 compiled against the updated wxwidgets (3.0.0) but can't launch with the following errors:

~/ saga_gui
saga_gui: relocation error: saga_gui: symbol _ZTI10wxListBase, version WXU_3.0 not defined in file libwx_baseu-3.0.so.0 with link time reference

~/ saga_cmd
saga_cmd: relocation error: /lib/libsaga_api-2.1.1.so: symbol _ZN13wxArrayString4InitEb, version WXU_3.0 not defined in file libwx_baseu-3.0.so.0 with link time reference

~/ pkgfile libwx_baseu-3.0.so.0
extra/wxgtk

That's also updated (along with wxpython) so I'm asking one of the SAGA devs where they think the issue is - I'll keep you all posted.

geosam commented on 2014-01-04 18:58

@saultdon I get the next error:

------------------------------------------------------------------------
po -c MLB_Interface.cpp -fPIC -DPIC -o .libs/MLB_Interface.o
In file included from PROJ4_Shapes.h:68:0,
from MLB_Interface.cpp:104:
PROJ4_Base.h:70:22: fatal error: projects.h: No such file or directory
------------------------------------------------------------------------

I think it is still necessary to use the libraries proj4. I'll check what the error, thanks.

saultdon commented on 2014-01-03 03:37

@geosam - I updated, cleaned and posted a PKGBUILD in my dropbox at https://db.tt/Ag5B3gt5

This doesn't include the old proj4 headers (noticed those weren't being extracted in the current build). Are those still needed?

FreeDesktop functionality is from the src package as well so those aren't in sources() anymore either.

Either way, here's a tidied up PKGBUILD that you can pull some changes in from if you like.

Jazzhouse commented on 2013-11-20 12:55

Would anyone be interested in creating a SAGA_CMD only version of this for servers without GUI? I tried myself but even if I add --disable-gui and removed the dependencies I cannot compile it. It still asks for a wxGTK. Maybe one of you can do it???

saultdon commented on 2013-09-16 17:43

Noticed the source was re-packaged with tar.gz. Src zipfile is still available, but this new file is a lot smaller.

http://sourceforge.net/projects/saga-gis/files/SAGA%20-%202.1/SAGA%202.1.0/saga_2.1.0.tar.gz

Alister.Hood commented on 2013-08-04 23:10

When building this I recommend people change the "gdal>=1.8.0" to just plain "gdal" - I experienced problems with it not claiming that the dependency wasn't fulfilled otherwise.

geosam commented on 2013-07-15 19:59

Saultdon, thank you very much for the contribution. I have included this dependency in PKGBUILD.

geosam commented on 2013-07-15 19:56

Saultdon, thank you very much for the contribution. I have included this dependency in PKGBUILD.

saultdon commented on 2013-07-13 04:38

I found the missing package with `pkgfile libwebkitgtk-1.0.so.0`:
# extra/webkitgtk2

So I had to add 'webkitgtk2' into the PKGBUILD as another dependency.

saultdon commented on 2013-07-13 03:55

Trying to install on a laptop with new arch install and getting a warning before the build fails:
/usr/bin/ld: warning: libwebkitgtk-1.0.so.0, needed by /usr/lib/gcc/x86_64-unknown-linux-gnu/4.8.1/../../../../lib/libwx_gtk2u_webview-2.9.so, not found (try using -rpath or -rpath-link)

I pasted some of the last part of the build output at pastebin - http://pastebin.com/x1F8UTEP