Package Details: safesignidentityclient 3.5-3

Git Clone URL: https://aur.archlinux.org/safesignidentityclient.git (read-only, click to copy)
Package Base: safesignidentityclient
Description: Smart card PKCS#11 provider and token manager
Upstream URL: https://pronova.com.br/download-tokens
Licenses: custom:copyright
Submitter: denisfalqueto
Maintainer: denisfalqueto (geyslan)
Last Packager: denisfalqueto
Votes: 9
Popularity: 0.011142
First Submitted: 2015-04-10 02:25
Last Updated: 2019-04-11 02:44

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

ralvesco commented on 2017-06-21 17:44

I'm not exactly a nobbie, but I can't say that I know much of it. I'd say that I'm an intermediary user. I figure somethings out on the go, so I'd work relative well with pacman and with AUR, the first I understand better, the second more or less. For instance, I start working with pacman using the same principles that I used in apt for debian based distros, but always reading the documentation of the command, using man and searching the meaning of the orders that I give to system. As for the makepkg I think it's shell, so I can understand relatively well and I'm good researcher. :)

denisfalqueto commented on 2017-06-21 16:20

@ralvesco: I can help you troubleshoot, but I need to know the level of familiarity with Arch that you have. Do you know well how to use pacman, makepkg and how AUR works? That will help we start.

ralvesco commented on 2017-06-21 16:08

Please, may you help me?

I've been using for a while now ubuntu without problems, except with STJ, then I resolved to change to archlinux (Antergos distro to be precise), but I couldn't install the safesign, it's crashes when installing the dependencies openssl098, pcsclite (pcsclite-git) and wxgtk2.8-light. I've tried to install each separated and using makepkg erasing this dependencies in the PCKGBUILD, but the same error continued to appear: gcc-lib coudl not be erased conflict with running gcc-lib=7.1.1.2...

I need to get this done so I can work from my laptop at home, but...

Thank you for everything, in advance.

denisfalqueto commented on 2017-03-31 03:13

Changelog for 3.0.101-3:

- Remove install file, because it's covered by hook system.

denisfalqueto commented on 2017-03-31 01:30

Changelog for 3.0.101-2:

- Don't depende on deb2targz anymore (thanks @geyslan)
- Fix bug for generated symlink

denisfalqueto commented on 2017-03-31 00:48

Changelog for 3.0.101-1:

- Create a symlink to /usr/lib/libaetpkss.so.3.0 -> /usr/lib/libaet
- Change dependency to wxgtk2.8-light. It doesn't depend of gstreamer0.10 (dangerously old) anymore
- Update to new midleware package version

geyslan commented on 2017-03-29 11:17

wxgtk2.8 is working beautifully now.

denisfalqueto commented on 2017-02-05 00:27

@geyslan: If wxwidgets needs to be compiled with different options and an specific ABI, maybe it would be better to convert this package in an snap package (or flatpack, but I preffer snap). That's something I was thinking about for some time. As the upstream software is binary, snap (or flatpack) is perfect for that.

geyslan commented on 2017-02-04 20:44

wxgtk2.8 nowadays has to be compiled with CXXFLAGS='-std=gnu++98' but after tokenadmin run for a few seconds and crash.

tokenadmin
/usr/bin/tokenadmin: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /usr/bin/tokenadmin)
Warning: Mismatch between the program and library build versions detected.
The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1010,wx containers,compatible with 2.6),
and your program used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.6).
terminate called after throwing an instance of 'unsigned long'
ERROR: signal: aborted (core dumped)

Is there a way to compile wxgtk2.8 using the same ABI (1002) as tokenadmin?

denisfalqueto commented on 2016-08-11 00:01

@pedrofuly, I think ccid is only needed for some models of tokens. Maybe it could be an optional dependenty, though. Thanks for letting me know.