Package Details: safesignidentityclient 3.5-3

Git Clone URL: https://aur.archlinux.org/safesignidentityclient.git (read-only)
Package Base: safesignidentityclient
Description: Smart card PKCS#11 provider and token manager
Upstream URL: https://pronova.com.br/download-tokens
Licenses: custom:copyright
Submitter: denisfalqueto
Maintainer: denisfalqueto (geyslan)
Last Packager: denisfalqueto
Votes: 9
Popularity: 0.124584
First Submitted: 2015-04-10 02:25
Last Updated: 2019-04-11 02:44

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

ralvesco commented on 2017-06-22 12:26

@denisfalqueto: The lines appointed were already uncommented.

denisfalqueto commented on 2017-06-22 12:09

@ralvesco: That package (wxgtk2.8-light) needs to be built with the multilib tool chain, so it can build 32 and 64 bit binaries. You should follow this

https://wiki.archlinux.org/index.php/Multilib#Enabling

That should do it.

ralvesco commented on 2017-06-22 11:31

@denisfalqueto: I've included the Key and changed the command line to yaourt -S safesignidentityclient, that suits better to the task (I think), than it installed the openssl098, but when installing the wxgtk2.8-light appeared one conflict:

- gcc-libs-multilib e gcc-libs estão em conflito.

Tried every choice given by the terminal, but nothing worked...

https://pastebin.com/GkqgscEH

denisfalqueto commented on 2017-06-22 03:12

@ralvesco: makepkg can check digital signatures if the packages provide ways to do that. For example, openssl098 provides digital signatures for the source files and these need to be validated by a public key.

You'll need to add those keys to gpg keyring for the user running makepkg. For example, you can use:

gpg --recv-keys D5E9E43F7DF9EE8C

This will add the public key with ID D5E9E43F7DF9EE8C in gpg's keyring for the current user. Maybe you'll need to add other keys as well, with a similar command.

ralvesco commented on 2017-06-22 02:26

@denisfalqueto I've run the following command: yaourt -i safesignidentityclient

And get this first error:

openssl-0.9.8zh.tar.gz ... FALHOU (chave pública desconhecida D5E9E43F7DF9EE8C)
==> ERRO: Uma ou mais assinaturas PGP não puderam ser verificadas!
==> ERRO: Makepkg não conseguiu compilar openssl098.

After that it's a loop as you can see in the whole process (https://pastebin.com/FdjH6TWH).

denisfalqueto commented on 2017-06-21 17:55

@ralvesco: Ok. I suggest using an AUR wrapper. I personally use pacaur, but you can choose any of the others (packer, yaourt, etc). By using one, you'll be a little isolated from the nuances of makepkg and downloading dependencies, without losing much power. So, could you try installing this package with an AUR wrapper of your choice? Send any errors here (use pastbin to avoid cluttering the comment session).

ralvesco commented on 2017-06-21 17:44

I'm not exactly a nobbie, but I can't say that I know much of it. I'd say that I'm an intermediary user. I figure somethings out on the go, so I'd work relative well with pacman and with AUR, the first I understand better, the second more or less. For instance, I start working with pacman using the same principles that I used in apt for debian based distros, but always reading the documentation of the command, using man and searching the meaning of the orders that I give to system. As for the makepkg I think it's shell, so I can understand relatively well and I'm good researcher. :)

denisfalqueto commented on 2017-06-21 16:20

@ralvesco: I can help you troubleshoot, but I need to know the level of familiarity with Arch that you have. Do you know well how to use pacman, makepkg and how AUR works? That will help we start.

ralvesco commented on 2017-06-21 16:08

Please, may you help me?

I've been using for a while now ubuntu without problems, except with STJ, then I resolved to change to archlinux (Antergos distro to be precise), but I couldn't install the safesign, it's crashes when installing the dependencies openssl098, pcsclite (pcsclite-git) and wxgtk2.8-light. I've tried to install each separated and using makepkg erasing this dependencies in the PCKGBUILD, but the same error continued to appear: gcc-lib coudl not be erased conflict with running gcc-lib=7.1.1.2...

I need to get this done so I can work from my laptop at home, but...

Thank you for everything, in advance.

denisfalqueto commented on 2017-03-31 03:13

Changelog for 3.0.101-3:

- Remove install file, because it's covered by hook system.