Package Details: sabnzbd 2.3.9-1

Git Clone URL: https://aur.archlinux.org/sabnzbd.git (read-only)
Package Base: sabnzbd
Description: A web-interface based binary newsgrabber with NZB file support
Upstream URL: http://www.sabnzbd.org
Keywords: network usenet
Licenses: GPL
Submitter: kvasthval
Maintainer: Revelation60 (fryfrog)
Last Packager: fryfrog
Votes: 260
Popularity: 0.219411
First Submitted: 2007-11-09 16:21
Last Updated: 2019-09-03 21:35

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 9 10 11 12 ... Next › Last »

Pietro_Pizzi commented on 2014-03-09 20:57

There are an 0.7.17RC1 with RAR 5.01 support. Is it possible to get that package? Eg. as a second beta AUR package if u think it isn't stable enough?

LeoKesler commented on 2014-02-22 14:51

error: File "SABnzbd.py", line 20
print "Sorry, requires Python 2.5, 2.6 or 2.7."
^
SyntaxError: invalid syntax

emphire commented on 2013-12-15 11:14

Here is a pkgbuild with using /var/lib and /usr/lib rather than /opt. It also removes the call that stops the service on upgrade as that is not considered a good practice in PKGBUILDS.
http://s000.tinyupload.com/?file_id=17766270613158397121

ice9 commented on 2013-11-19 00:30

/var/lib/sabnzbd/ sounds like an excellent suggestion for the default installation location of sabnzbd.ini. And with the /etc/sabnzbd.conf file, the user could always change it to another location if desired.

emphire commented on 2013-11-18 23:48

I second that suggestion. I've been running it that way for some time (but I used /opt/sabnzbd/config/sabnzbd.ini). It would be nice not to have to change the permissions back on each upgrade.

I'd suggest putting the config in /var/lib (ie: CONFIG_FILE="/var/lib/sabnzbd/sabnzbd.ini") and then putting everything else under /usr/lib/sabnzbd. You could add some symlinks to /usr/bin and /etc/sabnzbd.ini.

ice9 commented on 2013-11-18 23:09

By the way, if you set the location of the sabnzbd.ini file, then sabnzbd will also create the admin/ and logs/ directories in the same location, and those are the only files and directories that need to be writeable.

Which means that you can install all the other sabnzbd program files in a more standardized location than /opt/sabnzbd/ , like /usr/bin/ and /usr/lib/sabnzbd/

ice9 commented on 2013-11-18 22:54

http://pastebin.com/s6Pt1zct

How about changing the systemd unit file to include a configurable location for the sabnzbd.ini file? Keeping it in /opt/sabnzbd/ is not the best idea.

With the unit file linked above, the user would create an /etc/sabnzbd.conf
file with contents such as:

CONFIG_FILE="/home/sabnzbd/sabnzbd.ini"

or perhaps something in their own user directory if they have overridden the
User=sabnzbd with another user by creating the path/file:

/etc/systemd/system/sabnzbd.service.d/user.conf
[Service]
User=anotherusername


cdemoulins commented on 2013-08-11 08:54

It's already an optional dependency as it should be.

Anonymous comment on 2013-08-11 00:51

My downloads recently stopped working. Turns out it was because I only had ssl sources configured, and you now need python2-pyopenssl installed for that to work. Can that be added as a dependency?

mrhanman commented on 2013-08-10 22:25

This doesn't work for me, either. It starts up, but then does nothing with no indication of what is wrong.