Package Details: rvgl-bin 21.0125a-1

Git Clone URL: https://aur.archlinux.org/rvgl-bin.git (read-only, click to copy)
Package Base: rvgl-bin
Description: Rewrite of Re-Volt, popular R/C car racing game from 1999.
Upstream URL: https://rvgl.re-volt.io
Keywords: game racing
Licenses: custom
Groups: rvgl-basic, rvgl-original, rvgl-community
Submitter: svito
Maintainer: Huki (svito)
Last Packager: Huki
Votes: 9
Popularity: 0.41
First Submitted: 2019-05-04 16:36
Last Updated: 2021-01-27 13:38

Latest Comments

1 2 Next › Last »

Huki commented on 2020-11-17 10:34

@tomjtoth and @Kicer: RVGL optionally uses fluidsynth 1 to play midi files. Arch Linux only provides fluidsynth 2, which the game doesn't support, but the error is harmless. It shouldn't prevent the game from running.

I don't recommend symlinking .so.2 to .so.1. These are totally different versions of the library and are not ABI compatible. I do plan on adding support for fluidsynth 2 in a future update.

tomjtoth commented on 2020-11-12 11:14

after linking .so or .so.2 or .so.2.3.5 to .so.1 as seen below I get no error messages, nor does the game start, any advice? tried both on wayland and x11

sudo ln -s /usr/lib/libfluidsynth.so /usr/lib/libfluidsynth.so.1

tried on 2 different computers with same result.

false alarm, the RVGL.desktop does start the game and it runs fine

Kicer commented on 2020-10-23 14:48

Does not start due to missing libfluidsynth.so.1:

$ /opt/rvgl/rvgl Error loading libfluidsynth.so.1: libfluidsynth.so.1: cannot open shared object file: No such file or directory

Huki commented on 2020-07-24 20:29

Fixed.

svito commented on 2020-07-24 02:50

You did not test your PKGBUILD, it creates one {profiles,replays} directory instead of creating those 2 directories.

Huki commented on 2020-05-21 20:40

Should be fixed now. I'm in the process of updating these packages to pull content directly from our git repos (version tagged). It should make things a lot more stable for AUR users.

CJPortugal commented on 2020-05-17 02:17

The game-files-18.0328.zip archive is currently failing the sha256 validity check. Edit: Thanks for the update!

AlexanderCurl commented on 2020-02-12 15:15

The sha256 validate fails with the new update. Edit: fixed.

svito commented on 2019-12-25 15:34

@barfin Fixed now. When new version of pack is released they just overwrite old one and post new version in txt file on website.

Sometimes they don't announce these on re-volt.io website, so I have no idea they updated them.

miss_barfin commented on 2019-12-25 15:18

thank you so much for packaging this but some packages like 'rvgl-superpros' cannot pass the validity check