Package Details: rutorrent 3.9-1

Git Clone URL: https://aur.archlinux.org/rutorrent.git (read-only)
Package Base: rutorrent
Description: Yet another web front-end for rTorrent
Upstream URL: https://github.com/Novik/ruTorrent
Keywords: bittorrent rtorrent torrent
Licenses: GPL
Conflicts: rutorrent-plugins
Submitter: None
Maintainer: ljmf00
Last Packager: ljmf00
Votes: 124
Popularity: 0.000118
First Submitted: 2009-09-07 19:59
Last Updated: 2019-07-03 13:51

Latest Comments

1 2 3 4 5 6 ... Next › Last »

hamelg commented on 2019-08-19 19:58

I confirm, rutorrent 3.9-1 is broken. The fix reported by andreibsk works fine. thanks !

happycamper commented on 2019-07-28 16:25

Just installed with Apache and connected to rtorrent, but got the following error. I also can't load the settings popup:

ruTorrent cannot determine the UID of rTorrent user

And another required dependency (aside from rtorrent itself):

php-fpm

andreibsk commented on 2019-07-27 11:10

After I upgraded rutorrent to version 3.9-1 and rtorrent to 0.9.8-1 rutorrent seemed to have some communication problems with rtorrent. Symptoms included failure to load the settings popup, failure to detect and check the open connection port, etc.

The fix for this seems to be in the following commit and can be applied manually after install in the application folder (/usr/share/webapps/rutorrent/): https://github.com/Novik/ruTorrent/commit/ec8d8f1887af57793a671258072b59193a5d8d6c

binhex commented on 2019-04-12 10:45

@ljmf00 any chance of an update please?

MicroJoe commented on 2017-11-26 20:55

Got an error after install inside the webui: JS error: [http://127.0.0.1/rutorrent/js/stable.js : 1735] TypeError: this.dBody is undefined

Running inside nginx.

dracorp commented on 2017-06-27 16:01

I disowned package because I don't use it.

dracorp commented on 2017-06-27 15:49

Hi
How to prevent this:
-> Compressing package...
: Can't translate pathname 'usr/share/webapps/rutorrent/plugins/tracklabels/labels/трограммы.png' to UTF-8:
Some files contains Russian letters in filenames.

binhex commented on 2017-06-20 09:46

New release out, 3.8:- https://github.com/Novik/ruTorrent/releases/tag/v3.8

binhex commented on 2016-12-01 16:18

This is missing a dependancy required for the geoip rutorrent plugin to work (resolves ip to country). This is fixed by installing the php-geoip arch package:-

https://www.archlinux.org/packages/community/x86_64/php-geoip/

once installed you then need to enable the php module by adding extension=geoip.so to the php.ini file, snippet shown below:-

sed -i -e "/.*extension=gd.so/a extension=geoip.so" "/etc/php/php.ini"

Ketchup901 commented on 2016-08-10 10:28

fakeroot is required